MobileMe personal domain - publish from iWeb FAIL

Discussion in 'Web Design and Development' started by myawn, Sep 6, 2008.

  1. myawn macrumors member

    myawn

    Joined:
    Nov 9, 2006
    Location:
    Marietta, GA
    #1
    So, I figured that by moving my personal domain over from a local ISP to MobileMe, I'd benefit from the seamless integration with iWeb and everything would be very smooth.

    Instead, when I publish my website, it seems to be going only to a 'Sites' area on my iDisk, and not to my personal domain. I've done the steps of changing domain registration to web.me.com, and in MobileMe it shows the personal domain as being configured. When I'm working on the site in iWeb, it also shows my personal domain as being the site I'm working on.

    But when I go to my URL, I get prompted for a login and password (Authentication required: A username and password are being requested by <my personal domain url>. The web site says "idisk.mac.com".

    If I enter my mobileme login in, I just get a nearly blank page with "Not Found: Resource does not exist".

    I tried MobileMe online chat; they said it's because I haven't waited 48 hours after changing my CNAME records. But I can't imagine that I'm hitting a different site that just happens to prompt me for an idisk password and accepts my login info -- so I'm sure I'm reaching mobileme, but my info isn't published there.

    I can visit my published info at www.me.com/<myuserinfo>. iWeb seems to be ignoring my personal domain in favor of iDisk. How do I repoint it to the correct location? There doesn't seem to be any way to inspect the 'target' of the Publish operation.

    Thanks,
    Mike
     
  2. Mitou macrumors regular

    Joined:
    Jan 25, 2008
    #2
    iweb publishes your site in the following path
    idisk/web/sites/the name of folder that you chose for your site
    you basic address at that point is web.me/yourappleID/yourindexfile.
    When you change the CName in your apple account and thus redirect your page to your domain name you must also tell whoever sold you the domain name where to point to.
    Assuming you have done all that correctly after 24hours sometimes 48 (but rarely does it take this long) when you enter your domain name it will go to your site.
    Hope this helps
    M
     
  3. myawn thread starter macrumors member

    myawn

    Joined:
    Nov 9, 2006
    Location:
    Marietta, GA
    #3
    Solved ...

    I found the answer on another thread ...

    I was entering my domain name in mixed case. Web browsers handle this just fine, but apparently the personal domain feature in mobile me doesn't handle it correctly. It doesn't give any indication that it is rejecting the name, but once I removed the domain, and re-added it in all lower case, everything worked fine.
     

Share This Page