MobileMe Push Email Issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by and09890, Jan 6, 2009.

  1. and09890 macrumors newbie

    Joined:
    Oct 2, 2008
    #1
    I am having problems receiving push email on my iPhone (EDGE) from my MobileMe account, and I was wondering if anyone else had noticed a similar problem and found a solution.

    Basically, I don't receive any notification that I have received emails until I physically go into my MobileMe inbox on the phone. Then it "phones home" and I receive the emails a few seconds later. I have watched it do this and emails that were sent hours earlier suddenly appear.

    I checked the settings on the iPhone, and MobileMe is set to "Push", and the general setting of "Push" is enabled, so that should be right. Does anyone have any suggestions?

    Thanks.
     
  2. andyblila macrumors 65816

    andyblila

    Joined:
    Jul 8, 2008
    Location:
    On My iPhone, or my iPad?
    #2
    You have to enable push.
    Settings>Fetch New Data>Enable Push
     
  3. and09890 thread starter macrumors newbie

    Joined:
    Oct 2, 2008
    #3
    I did, as per my original post, I enabled push both in the general setting, and individually for MobileMe. It still doesn't work as advertised.

    I would take it to the Genius Bar, but it is a bit of a hard problem to replicate.
     
  4. and09890 thread starter macrumors newbie

    Joined:
    Oct 2, 2008
    #4
    Ok, problem solved by removing the MM account and re-starting it.
     

Share This Page