MobileMe: Read Mail on Mac, Stays Unread On iPhone

Discussion in 'iPhone' started by kolax, Jan 11, 2009.

  1. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #1
    Just as the title says. Had a wee search but couldn't find anything on it (awkward problem to phrase/search for).

    Basically, if I get a new email and I open it on my Mac, it stays unread on my iPhone. I've left it for hours and it never syncs back up. However, once I open the Mail App, but don't actually read the email, it syncs up.

    On the iPhone, I have MobileMe set to sync everything.
     
  2. jc1350 macrumors 6502a

    Joined:
    Feb 4, 2008
    #2
    That's how it works. The new mail notification on the iphone doesn't automatically go down until you go into the mail application.
     
  3. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #3
    Ah ok...disappointing.

    I can get the email pushed but a push update when the Mail is read on another device?
     
  4. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #4
    Mine does that now, since the 2.2 release i think

    prior to this it used to work like exchange push, changes on computer are automatically shown on the phone
     
  5. ukmacpro macrumors member

    Joined:
    Oct 1, 2008
    Location:
    London
    #5
    Are you sure? I'm almost positive that the number or emails I have waiting on my iPhone changes, even without opening the mail app.
     
  6. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #6
    So 2.2 caused this? Bug?
     
  7. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #7
    fairly sure it was fine before the upgrade

    the little dock icon used to have an accurate number of emails, without opening up the app

    will give it a test with exchange tomorrow when at work, but I am sure that updates the count (as MM used to)
     
  8. fishkorp macrumors 68020

    fishkorp

    Joined:
    Apr 10, 2006
    Location:
    Ellicott City, MD
    #8
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    This happens to me since 2.2 as well. Used to work fine.
     

Share This Page