MobileTerminal doesn't work for me

Discussion in 'Jailbreaks and iOS Hacks' started by cashonly, Nov 12, 2009.

  1. cashonly macrumors newbie

    Joined:
    Sep 25, 2009
    #1
    MobileTerminal does not work for me.

    I have an iPhone 3GS running 3.1.2.

    I installed MobileTerminal from Cydia.

    But, everytime I run it, it shows the keyboard for about 1 second, then the keyboard disappears and I'm back at the springboard.

    I shut my phone down and restarted and still have the same problem.

    I uninstalled it, re-booted, re-installed and re-booted and it acts the same.

    What am I doing wrong?
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    Probably nothing. I searched on Google and it seems there are lots of threads on the same issue: http://tinyurl.com/ykz3jk3

    Looks like someone else already reported it to the team who coded MobileTerminal: http://code.google.com/p/mobileterminal/issues/detail?id=151

    I guess I won't be upgrading to 3.1.2 anytime soon. :)
     
  3. m3coolpix macrumors 6502a

    m3coolpix

    Joined:
    Dec 24, 2007
    #3

    Hmmm. I'm also on a 3Gs on 3.1.2 (older bootroom though) and I just installed MT (before seeing your thread) and changed my passwords. Worked (and still working) with no problems.

    Maybe do an iTunes sync and retry?
     
  4. DeLoMan macrumors regular

    Joined:
    Nov 6, 2008
    #4
    My MobileTerminal gave me some trouble after upgrading MobileSubstrate. It crashed once, but then seemed to be working after I tried opening it again.
     
  5. m3coolpix macrumors 6502a

    m3coolpix

    Joined:
    Dec 24, 2007
    #5
    FWIW, I've not upgraded to the latest MobileSubstrate yet. Still showing 0.9.3051-1 as the installed version.
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    I've had no problems with MobileTerminal on my 3GS with 3.1.2 and the newest version of MobileSubstrate (0.9.3087-1).
     
  7. ilkevinli macrumors 6502

    ilkevinli

    Joined:
    Apr 8, 2006
    Location:
    NYC
    #7
    If you installed the ROCK app from the BlackRa1n RC1 app, thats your problem. It was messed up and caused Mobile Terminal to crash. The only way to fix it is to restore and rejailbreak.
     
  8. Degrassiman macrumors newbie

    Joined:
    Sep 3, 2010
    #8
    Mt

    I have been having the same problem with my iPod touch 3G.any suggestions?
     
  9. cashonly thread starter macrumors newbie

    Joined:
    Sep 25, 2009
    #9
    I never got it working and just ssh'd in from my pc to do what I needed to do.
     
  10. mlts22 macrumors 6502a

    Joined:
    Oct 28, 2008
    #10
    I had to manually find the Debian package for it and install it via ssh for the terminal app to work right.
     
  11. Sharkboi033 macrumors newbie

    Joined:
    Apr 16, 2011
    #12
    The solution

    I have the solution. Go onto cydia and search mobileterminal. It will come up with mobileterminal (NEW) download that and it will work. :)
     

Share This Page