Mocha Telnet Help

Discussion in 'iOS Apps' started by jalpert, Aug 21, 2008.

  1. jalpert macrumors 6502

    Joined:
    Jan 30, 2008
    #1
    Okay here is the issue:

    I am trying to connect to work

    We have a Windows Small Business server 2k3 with VPN enabled pptp

    At home over wifi I can log into the vpn on the phone and connect fine to our telnet server.

    Over 3G I log into the VPN it appears to connect to our telnet server but hangs at "telnet negotiation"

    If nothing else have changed, why can't I connect? It has to be something with the 3G, I tried edge for grins, no luck.

    I contacted support, their theory is that I'm not actually connecting to my telnet server but something else, that's why it's dying. But, it works over wifi... Anyone have an idea?

    I know the VPN is working because I donwloaded Mocha RDP Lite and was able to connect RDP using an internal IP address.
     
  2. CommanderData macrumors regular

    Joined:
    Dec 1, 2007
    #2
    I am able to connect over EDGE to my VPN and Telnet into my router without issue, but I am using pTerm. Maybe it's a bug with Mocha?
     
  3. jalpert thread starter macrumors 6502

    Joined:
    Jan 30, 2008
    #3
    I did get it to work, but not how I wanted to.

    I think it is a bug with Mocha.

    Since it works via wifi, I'm going to assume all my settings where correct.

    The problem was that I was connecting pptp to one subnet and trying to telnet to another. I enabled pptp on a server on the same subnet, setup my firewall and it worked fine.

    If you are using mocha products, and you need to access a subnet that is not the same as the box you vpn in to you might encounter an issue...
     

Share This Page