MOCHA VNC - outside house help!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mervman, Aug 4, 2008.

  1. mervman macrumors newbie

    Joined:
    Nov 18, 2007
    #1
    Hi,

    I have downloaded the new mocha VNC app (the full one) and i have managed to be able to view my desktop when im on the same network without any difficulty.
    I cant manage to set up the app to be able to access my computer from outside the house using 3G. I set up an account with DYNDNS.com. However i do not really know what i am doing and do not know what the settings should be to enable this feature.
    Please would someone be kind enough to give me some step by step instructions!!??
    Thanks
    p.s. im using leopard!
     
  2. juice831 macrumors member

    Joined:
    Aug 1, 2008
    Location:
    Salinas, CA
    #2
    do you have a router or are you behind any kind of firewall? if so, you need to forward the vnc server port to the computer's internal network ip. The Mocha VNC client never allowed me to use the iPhone app on edge but I haven't tried it on 3G, it wouldn't work outside of a wireless network. Let me know what kind of network setup you have at home and I will try and help you with some steps.
     
  3. Scooterman1 macrumors 6502a

    Scooterman1

    Joined:
    May 15, 2008
    Location:
    Houston, Tx
    #3
    Do a search on here for Step by Step instructions. You DO need to get through your Routers Firewall. You need to port the router to pass through Port 1080.
     
  4. juice831 macrumors member

    Joined:
    Aug 1, 2008
    Location:
    Salinas, CA
    #4
    I'm not sure if you were trying to tell me how it may be done or just reinforcing what I said? I don't mean this in a bad way
     
  5. heyp macrumors 6502

    Joined:
    Jan 29, 2008
    #5
    is this possible to use using 3G instead of wifi? I was under the impression that it was a wifi only deal
     
  6. juice831 macrumors member

    Joined:
    Aug 1, 2008
    Location:
    Salinas, CA
    #6
    I haven't tried it on 3G because it's not offered in my town but with EDGE it doesn't work. I think it is wifi only.
     
  7. mervman thread starter macrumors newbie

    Joined:
    Nov 18, 2007
    #7
    hi thanks for your help guys - what details do you want of my router and network?
     
  8. juice831 macrumors member

    Joined:
    Aug 1, 2008
    Location:
    Salinas, CA
    #8
    since you already have it working on the network, I assume you have remote management enabled on leopard. Next you will need your computer's network ip and you can find this by going to system preferences>sharing or system preferences>network. Once you have that, go to your router's setup page and find the port forwarding page. Here you will fill out the port you want to forward (5900 is default for Mocha VNC) and your computer's network ip. That's all you need on the server side.

    The DynDNS service automatically updates your external ip whenever it changes, if it's dynamic of course. Your router must either have a DynDNS feature or you need to run a DynDNS updater client on your network for it to work. Once that's all done, you can configure your iPhone app with your DynDNS address and connect from outside of your network. (I don't think Mocha VNC works with EDGE or 3G so you would have to be in a different wireless network)

    hope that helps!
     
  9. svndmvn Guest

    Joined:
    Nov 6, 2007
    Location:
    Italy
    #9
    I need some help as well,i have a dyndns account,a Trust ADSL2+ modem/router connected to an airport extreme and then to my Mac,the trust supports ddns, I typed in that section my account info and also forwarded both TCP/UDP 5900 ports in the airport utility and using the modem's IP to the IP I got in my network's preferences as mentioned above by someone,and in this case it's the IP given by my airport,10.0.1.200,I tried with other IPs as well,even with the one that corresponds to the dydns host and the IP given by the first router..
    iPhone 3g connected via wifi to the same network as the Mac- I can see it if I type in the network's IP,10.0.1.200 but of course not if I am connected through someone else's wifi
    iPhone same network as the Mac- I can't connect mocha lite to the IP given to my by dydns
    and if I go to that IP through my Mac or iPhone's safari i have to enter my trust's password and see it's settings page,that's it..
    what am I doing wrong?
     
  10. juice831 macrumors member

    Joined:
    Aug 1, 2008
    Location:
    Salinas, CA
    #10
    I understood most of your post but had some trouble understanding a minor portion. Does your ADSL modem/router combo have it's own firewall? Also, I assume the AEBS is acting as the main router so did you disable the router feature on your ADSL modem/router? The modem should be acting as simply a modem so you wouldn't be using the DynDNS service there, you would be using it on the AEBS and the AEBS doesn't have a DynDNS feature.
     
  11. snowangel macrumors newbie

    snowangel

    Joined:
    Jun 4, 2010
    Location:
    Midwest
    #11
    Working Setup

    I use Mocha VNC with my iMac and it works over my network, on other networks, and 3G. Here is my setup:

    MochaVNC
    VNC Server IP Address: This is my router's WAN IP Address
    VNC Server Port: 5900
    Password: same as defined below
    Name: name your connection (i.e. iMac Away)
    Mac OS X Server: Off
    Mac OS X Keyboard: US
    Save Password(s): On
    32-bit Color Mode: On
    Mouse with offset: On
    Show Warnings: Off
    Vibrate: On
    View Only: Off
    Motions: Off
    Wireless Keyboard: Off
    Toggle blue buttons: On
    Close session on exit: Off

    Mac Settings:
    Open System Preferences
    Under "Internet & Network" select "Sharing"
    Enable Screen Sharing (In Tiger it's called Apple Remote Desktop) & Allow access to All Users
    Click on the Computer Settings button
    In the popup window Check "VNC viewers may control screen with password:" and type in a password
    Click on Ok
    (credit for mac setup instructions goes to mochasoft.dk)

    Router Settings
    Log into your router (usually by typing your router's address in your web browser; i.e. 192.168.0.1)
    Find the page that controls port forwarding (either for all computers or for just the computer you want to connect to)
    Add a port forwarding rule for TCP and UDP and specify the port start, port end, and port map as 5900
    (since each router is unique, you'll need to reference your router's user manual on instructions for adding port forwarding rules)

    That's it! You are all set to access your computer wherever you are.
     

Share This Page