Modded HOSTS file?

Discussion in 'Jailbreaks and iOS Hacks' started by ToyotaGuy23, Jun 3, 2009.

  1. ToyotaGuy23 macrumors newbie

    Joined:
    Jun 3, 2009
    #1
    Hello MacRumors!

    New owner of an iPhone 3g here.
    I have 2.2.1 firmware installed.
    I have jailbroken my device.
    I have installed Cydia, Installer, OpenSSH, and various other goodies.

    What I would like to do is use a modified HOSTS file from here

    I've had success using this HOSTS file in both Windows and Linux Operating Systems. I've grown to like the way it works, the ads never show, you just get a banner saying "cannot connect" or "cannot be displayed."

    I'd like to incorporate this into my new iPhone.

    Currently, I am using a Windows Vista laptop. I have set up OpenSSH and gotten into the correct directory called (/etc) The program I've used is called WinSCP.

    I copied the iPhone's HOSTS file over to Vista's desktop, and opened the file up with Notepad. I copied the entries from the NEW HOSTS file to the old HOSTS file and replaced it into the /etc directory. Originally the HOSTS file was 236kb, and now it's 611kb, so I know it worked.

    I use one of the most ad filled sites I have come across for testing in my other systems. It's also a great IRC search engine, called www.packetnews.com.

    When successful, the banners on the top and sides are blocked completely, and don't show up. Pop ups are gone, and so on.

    This is NOT the case with my iPhone.
    Have I modified the incorrect file?
    Where did I go wrong?
     
  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #2
    I've followed the instructions from here and it works fine.
    Did you restart your iPhone ?
     
  3. ToyotaGuy23 thread starter macrumors newbie

    Joined:
    Jun 3, 2009
    #3
    Yes I did, I guess maybe that file had the incorrect formatting...?
    Anyway those instructions worked for me too.
    Thanks so much for posting it!
     

Share This Page