modem will not disconnect

Discussion in 'macOS' started by Attonine, Jan 7, 2008.

  1. Attonine macrumors 6502a

    Joined:
    Feb 15, 2006
    Location:
    UK
    #1
    I have a Nokia 6120 classic which is used as a 3G (HSDPA) modem via bluetooth on leopard. Generally it works fine but when I disconnect, it doesn't. The telephone icon in the menu bar simply says disconnecting. The phone says it still has a connection, though no data is being passed. The drop down menu from the menu bar has disconnect greyed out do I can't try again. Logging out does not solve the problem, only a reeboot. However, if I change my network location from the :apple: menu , I can connect to the internet with my external USB modem. Change back to the bluetooth and it is still saying disconnecting.

    I have checked console, and I think this is referencing the issue (it is repeated a lot):

    Jan 7 17:49:46: --- last message repeated 5 times ---
    Jan 7 17:49:46 ***n-*****ns-computer kernel[0]: dlil_output: output: output error retval = 37
    Jan 7 17:49:46 ***n-*****ns-computer kernel[0]: dlil_output: output error retval = 37
    Jan 7 17:49:46: --- last message repeated 2 times ---
    Jan 7 17:49:46 ***n-*****ns-computer kernel[0]: al = 37
    Jan 7 17:49:46 ***n-*****ns-computer kernel[0]: dlil_output: output error retval = 37


    I've googled this, and there are other people out there who have had this issue, though I haven't found a solution.
     
  2. Attonine thread starter macrumors 6502a

    Joined:
    Feb 15, 2006
    Location:
    UK
    #2
    I think I may have fixed this by using a different modem script, but it's still early days.
     
  3. pogmothoin macrumors newbie

    Joined:
    Nov 12, 2007
    Location:
    Dununda
    #3
    i have some issues like this too .. what was the script you found and how did it work out???
     

Share This Page