OS X Modern Warfare 2 - Strict NAT

Discussion in 'Mac and PC Games' started by bensimpsy, Jul 3, 2014.

  1. bensimpsy macrumors newbie

    Joined:
    Sep 5, 2013
    #1
    Hi Guys

    Not sure if here is correct place to ask this, so if not i apologise

    Been playing MW2 through bootcamp for a while, upnp always worked fine and i never had any drama's

    Since steam released this for mac I thought you beauty no more rebooting, however I always have a strict NAT. I ma pretty new to Networking in OSX so maybe I have missed something?

    When i boot the game it asks me to allow the incoming connection which I allow, and makes no difference.

    I have turned off firewall in OSX - no difference

    set DMZ up on my router with my Mac's ip address - no difference

    Running out of ideas? anyone else faced similar situation?

    My modem/router is a TP-Link W8980
     
  2. AspyrSupport macrumors newbie

    Joined:
    May 28, 2014
    #2
    RE: Modern Warfare 2 - Strict NAT

    First, check that you have the following ports opened on your router:

    TCP Port 80
    UDP Port 28960, 3300, 3101, 3104, 3005, 27019

    MW2 defaults to 'Strict' most often. Opening ports will ideally set the NAT to 'Open', though MW2 will sometimes still display 'Strict', even when connectivity improves.

    If you still run into problems connecting to servers, please open a ticket with us directly so that we can further assist you. support@aspyr.com
     
  3. bensimpsy thread starter macrumors newbie

    Joined:
    Sep 5, 2013
    #3
    Awesome - when I get home I will give it a shot
     

Share This Page