Modifier keys stuck in nonstandard configuration

Discussion in 'MacBook Pro' started by I82Much, Dec 23, 2008.

  1. I82Much macrumors newbie

    Joined:
    Dec 23, 2008
    #1
    Hello people, I tried searching for this and found nothing directly relating to my problem. Sorry if this is a duplicate.

    I am using a brand new MacBook Pro, one with the glossy screen and glass trackpad. I plugged in my Windows ergonomic keyboard. As such, I had to switch the option and meta keys to be in the correct place. Everything worked fine.

    After unplugging the keyboard and shutting down the computer to bring home for winter break, the modifier keys are stuck in the reversed position. For instance, I have to press Option Tab to cycle through applications rather than Command Tab. I went back into the System Preferences -> Keyboard -> Modifier Keys and reverted them to normal and it still does this. I rebooted and this did not fix the problem either.

    Unfortunately I do not have the keyboard (it's at school) so I cannot reattach it to see if that fixes the problem.

    Any idea how to fix this? Pressing modifier keys is now a huge pain as the option key is not conducive to frequent pressing.
     
  2. TitoMonkey macrumors newbie

    Joined:
    Dec 28, 2008
    #2
    Plug in the keyboard that caused the problem

    I had the identical problem with my Macbook Pro. I plugged in a Dell USB keyboard at work and re-mapped command and option. I then took the machine home and found the internal keyboard was re-mapped, even though the System Preferences showed the keyboard set to defaults. I'm fairly sure this must be a bug in the operating system; plugging in the Microsoft USB keyboard I had at home did not clear up the problem. I could swap the keys on the Microsoft keyboard, but not the Macintosh internal keyboard!

    Back at work today, I plugged in the original Dell keyboard and set everything back to defaults.

    As an aside, before I ever plugged in an external keyboard, I was able to swap the modifier keys back and forth with no issues.

    Good luck.
     
  3. I82Much thread starter macrumors newbie

    Joined:
    Dec 23, 2008
    #3
    Great to hear!
    Unfortunately I will not have access to that keyboard for a few more weeks. Hopefully I won't get to used to this screwed up keyboard configuration!

    We should probably submit a bug report or some such to Apple... I can't imagine we're the only two that have faced this problem.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    Go to System Pref.—>Keyboard & Mouse

    Then go to the keyboard tab and the bottom should have a button labeled "Modifier Keys"

    Click that and there you should be able to set what each key is bound to. You can customize it for individual keyboard, say use the default for your integrated keyboard and a different layout for your Windows keyboard.

    You can always just click "Restore to Defaults" and then close the window.

    I hope that resolves it.
     
  5. cineologist macrumors newbie

    Joined:
    Dec 30, 2008
    #5
    Experiencing exactly the same...

    I am experiencing exactly the same issue and funny how we're going through the same thing - new MacBook Pro with glass trackpad and going home for the holidays, leaving behind my Microsoft Natural Keyboard.

    I restored the default settings for the Modifier Keys and it didn't do anything. I even restarted and all that. Still stuck based on the Microsoft Natural Keyboard.

    I will need to find a laptop other than the Microsoft while I'm still on the road and hope that will do the trick but I have already posted it on Apple's feedback page to report the bug.
     
  6. I82Much thread starter macrumors newbie

    Joined:
    Dec 23, 2008
    #6
    I got back to school and plugged in the old keyboard and toggled the key settings. Sure enough that fixed it.

    What a bizarre bug.
     
  7. corduroygt macrumors regular

    Joined:
    May 29, 2005
    Location:
    New York, NY
    #7
    I have the exact same problem with my aluminum macbook. I hope plugging the external keyboard back will fix the problem, but I don't go home until tomorrow night.
     
  8. corduroygt macrumors regular

    Joined:
    May 29, 2005
    Location:
    New York, NY
    #8
    Just got off the phone with Apple support and my problem is solved.
    Here's the fix:
    Go to your library/Preferences folder
    move all the files to a new folder in your desktop, leaving your existing preferences folder empty
    Log out and log back in, your keys should be back to normal.
    Copy your old prefs back, overwrite the existing ones that osx created, and all should be back to normal.
     
  9. jove4015 macrumors newbie

    Joined:
    Dec 22, 2006
    #9
    Just happened to me on a brand new macbook (it's a spare from the company while my normal mbp is being repaired). My MBP never had this problem, I wasn't even aware it happened to anyone (glad to know in case any users at work have this issue), but it happens with this macbook too. I think it's probably an issue with the new laptops (my guess is they tried to do something fancy here, like let the options be separate for different keyboards, but then screwed up in the process).

    Anyone find out what the *precise* preferences file it is that you need to get rid of? I hate it when they just tell you to trash all of them, it's so sledgehammer-to-kill-a-gnat...
     
  10. kentquirk macrumors newbie

    Joined:
    Mar 5, 2009
    #10
    Exact file varies

    Two things:

    a) This is your personal library preferences (~/Library/Preferences) rather than /Library/Preferences

    b) The file is probably machine specific. I did this in terminal:

    touch foo
    (edit the system prefs keyboard modifiers)
    find . -mnewer foo

    That gives me a list of all the files changed since I touched foo. What I found was that a file in ~/Library/Preferences/ByHost, called .GlobalPreferences.[longhexnumber].plist was modified. Probably that long hex number is specific to my machine. But I deleted that file, rebooted, and my machine was back to normal.
     
  11. yogiken macrumors newbie

    Joined:
    Mar 5, 2009
    #11
    Problem Solved

    kentquirk's suggestion worked perfectly to fix this issue on my MBP. I deleted the same ~/Library/Preferences/ByHost/.GlobalPreferences.[longhexnumber].plist file, logged out and back in, and was able to use System Preferences to set my keyboard modifiers properly. Thanks for the simple fix.

    Ken

    ps. I use the find command pretty much every day and never used -mnewer. Heh, I guess I should go reread the man page; probably other goodies in there I'm not benefitting from.
     
  12. ButchySilver macrumors newbie

    Joined:
    Jul 17, 2010
    #12
    Same problem

    Hey, I'm having this same problem, except I can't find that exact preference file on my machine. My only solution so far is to delete the whole preferences folder, but then when I copy it back in and reboot I get the same problem. Has anybody here had any experience with this issue? Any advice would be greatly appreciated!

    thanks


    -Butchy
     
  13. neenja macrumors 6502

    Joined:
    Jul 17, 2008
    #13
    To find that .Global pref file mentioned above, you have to enable showall files, heres how:


     
  14. 37b macrumors newbie

    Joined:
    Jul 30, 2011
    #14
    Welp I am stuck. Took it to the Apple store and the genius tried everything listed here (I think he Googled for a fix and came across this thread).

    I have had this problem for months and never really bothered to look into a fix since it was easily remedied by altering the modifier keys. Then I upgraded to Lion, had a free day off and decided to take it in. I think the upgrade to Lion might have set the keyboard in this condition another way because none of these solutions work. I even did a diff on the .GlobalPreferences.XXXX file before and after setting it to factory defaults and when it is set to default there are no mentions of ModifierMappings.

    I curse the day I ever stuck a crummy Dell keyboard in this thing :D
     
  15. Jeffree macrumors newbie

    Joined:
    Sep 3, 2010
    #15
    Hi,

    I'm having the same issue on 10.6.8, where the option and command keys have been switched. However, I'm using a Logitech keyboard and Synergy in order to share my PC keyboard with my Mac. I've used this configuration in the past with no problem, until last month, when the keys switched for some reason.

    I've tried the suggestion of deleting global preferences but it was no help.

    In the system preferences, keyboard panel, when I try to change keyboard type nothing happens. In the modifier keys panel, the keys are set correctly.
     

Share This Page