Mojave boot problem

Discussion in 'macOS Mojave (10.14)' started by MagnusVonMagnum, Jul 11, 2019.

  1. MagnusVonMagnum macrumors 603

    MagnusVonMagnum

    Joined:
    Jun 18, 2007
    #1
    I installed Boot Camp with Windows 10 Pro under El Capitan with my new 2TB SSD drive. I then upgraded to Mojave on the Mac side. But I'm having a recurring issue with booting into the Mac side. I thought it had to do with turning TRIM control on from OS X the first time it happened and I ran first aid from recovery and it found one anomaly and then said it was good. It still wouldn't boot, though. It just hung on the Apple logo (no loading progress bar). Windows 10 still booted fine. Then I read about verbose mode (CMD-V) and I was in the recovery USB stick I have and selected it to use the OS X startup partition from there and then held CMD-V and it showed the booting and booted normally! OK...

    So I've been using both Mojave and Windows 10 for a couple of days now, but I believe I had it set to startup to Windows unless I hold OPTION and select OS X. So I switched it back to OS X from Mojave and rebooted to Windows, made a few changes there and restarted (expecting it to go to OS X automatically). Well, it went to the frozen Apple logo again. I rebooted and held the verbose key and it showed what looked like a smaller resolution version of the mode (like it was in a window) and it went so fast I couldn't see what it originally said, but it soon started repeating "Attempting system restart... MACH Reboot" over and over again. So that's apparently what's going on in the background when it just shows the frozen Apple logo. I booted into the recovery USB stick again. I ran the disk utility and it showed no issues at all. I told it to boot default to Windows again, but then used the option key and selected OS X and it booted up fine again.

    Thinking there might be a connection between Windows 10 not being able to see OS X for a restart (from the Boot camp tray program), I selected from Mojave to boot to OS X and just let it reboot. It got stuck again. I booted into the recovery USB stick and set it to Windows and rebooted with the option key expecting it work again and NOPE. It won't boot.

    At this point, I'm not sure what the problem is that's causing it to have that issue. Windows always boots fine from the option menu or when set to automatic boot to Windows from the recovery startup disc selection. OS X.... I don't know at this point. I thought there was a pattern related to the startup disk selection since it worked for several days with me manually switching back and forth via the option key at startup (leaving it set to default to Windows during that time), but the fact the select Windows and then option boot isn't working this time, I just don't know. I'm typing in Windows 10 right now since I can't get it to boot Mojave. The only step I didn't repeat exactly was running Disk Utility First Aid before telling it to boot to OS X (the first time I definitely told it OS X; the second time I think it was set to Windows so that didn't seem to be the issue).

    What could be going on here? I know I read Windows can't read APFS. Well, it can here because I bought MacDrive and it can read/write my HFS+ media drives and it has the OS X partition set to read only (and it can read it just fine). But the fact Boot Camp can't "see" an OS X partition to boot from is weird as I read it should be able to see that for booting regardless. I get the feeling the boot issue is somehow related to that startup disk and/or boot camp startup selection malfunctioning (by not changing the settings when it was working, it kept working until I tried to change it again). Bu I don't know what and I have no idea how to fix it long term. It kind of sucks, really.

    If someone has an idea, let me know. Thanks.
     
  2. MagnusVonMagnum thread starter macrumors 603

    MagnusVonMagnum

    Joined:
    Jun 18, 2007
    #2
    After much fiddling (and repeating the same steps that didn't seem to work before), I got it to boot again into OS X with it set to startup from OS X and it seems to be startup normally on reboots and will startup Windows 10 using the option key and reboot back to OS X again afterwards. All I can think of (other than a pure random-like bug) is that changing the startup disk in preferences some way, some how causes the problem and "maybe" the inability of Boot Camp to see OS X as a boot location is telling of some hint of what's wrong, but seeing I know of no way to correct it, the best thing I can do for now is leave it set to OS X as the startup all the time and use the option menu to go to Windows if I need to use it. Time will tell if that avoids the problem or if it just happens randomly or whatever....
     

Share This Page

1 July 11, 2019