Mom's iPhone can't connect to WiFi (WEP - "incorrect password")

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Leah Frances, Mar 14, 2008.

  1. Leah Frances macrumors newbie

    Mar 14, 2008
    My Mom got one of those refurb'd AT&T iPhones ($200!). Who knew she was so cool? She does NOT have the data service because everywhere she goes she has access to WiFi. Here's the problem: Dad has set up a WEP WiFi at home and Mom can't connect.

    Here's what happens:
    - iPhone can 'see' the network'
    - iPhone requests password (Dad insists that it is not a password because it is really a passkey, or something)
    - I disabled the auto-caps and entered the 13 character passkey
    - iPhone reports back with a "incorrect password" error.

    I've poked around the forums and am having some trouble.
    1. When I click on the network with the blue arrow it does not give me the option to "forget this network". It's just not there.
    2. I do not get the option to change the WEP password from WEP hex or ASCII - it just isn't there.

    Any ideas on how to proceed? Or why the phone is missing these things? I am going back tomorrow and would like to help her get online.

  2. Eraserhead macrumors G4


    Nov 3, 2005
    Prefix with a Dollar ($)

    Better yet use WPA security, as it can withstand more than a trivial assault (WEP can be cracked in less than 1 minute).
  3. Leah Frances thread starter macrumors newbie

    Mar 14, 2008
    I know WEP isn't the best security. But, it isn't my network, and for some reason (god knows what) Dad wants to use it. So, Mom is stuck with trying to connect to the WEP.
  4. wandererrob macrumors newbie

    Nov 25, 2008
    I just got around thisa problem myself just minutes ago and am now making the rounds to the forums I sought info in.

    Here's what I did to get onto my home network with my new iphone. I had to enter the WEP key. Not the password my laptop uses, but the 26 character Hex key. I can only hope I only have to ebter it once though! LOL!

    But it did work for me and my iphone is now on our home network wifi.

    Good luck! :D
  5. Rushmore macrumors newbie

    Feb 2, 2009
    Cracked it!

    Had this problem for a couple of days now, and finally cracked it!

    Bear with me through explanation, as I'm sure it'll solve your problem. With my router, I have WEP protection. The passkey (i.e. 7A533AA1C7) is generated by me inputting some text (in this case 'nickiscool') and the router converting it to hex or something. I then have four options of codes similar to the above (let's call them 1,2,3 & 4). I select one of these, apply the settings, and thats the passkey set.

    Then, I go to my wireless settings on my PC, try to connect to the wifi and input the passkey. Crucially, beneath the passkey entry bit is a 'Key Index', this has to be set to the correct number (1,2,3 or 4) for the connection to work.

    For example, I have chosen passkey 2, so I must set my key index is set to 2. Everything works and I'm all happy. That is until I try to find the wifi on my new iphone...

    It finds the network, but every time I input the correct passkey, it says it's incorrect. Frustrating! But, what it seems to me is that the iphone's 'Key Index' is permanently set to 1. So, to fix...

    - Go into your router settings, generate passkeys and pick option 1.
    - Go into your wireless settings, input the new passkey and set 'Key Index' to 1 so your wireless keeps working.
    - Attempt to connect with your iphone, use new passkey.
    - Bet it works!

    Best of luck with it. Tricky and annoying problem, but this seems to have fixed it for me, and I tested it a couple of times to make sure the theory is correct.


  6. nfjimc macrumors newbie

    Jul 1, 2010
    Wish I was a Betting Man...LOL

    Well your solution did not work for me. I have tried everything that I can find on the net. Rebooted everything, reset my network settings on the iPhone, changed my WEP key, and the iPhone keeps saying "Incorrect Password". I even added the phone to the allowed MAC address table. I have 3 laptops and an Xbox all working perfectly on my home wireless network, but not teh phone. My router is a Belkin, not sure of the model number as I am at work righ now. I know the phone works on WiFi because I can connect to our WiFi here at the office. Any other suggestions?
  7. summercruise macrumors newbie

    Dec 27, 2010
    ipod password connection problem fixed!

    So from what I read on a few other helpful sites and forums (mainly this one) , I figured out what the issue was for my ipod/password/connection problem.
    I have the new 4G ipod touch just earlier this week, and also a new router (DLink) when installing my new router to be compatible with my ipod it took a few tries but i finally found that the new ipod wont work with a WPA security, only WEP or lower.
    That was one delemia I had.
    The second was many like yours. I wasn't able to connet, even though my ipod had found the connection and told me 'wrong password'
    so, when i went into my settings and went to type the password i instead typed the WEP key into the password and it worked perfectly..
    I have yet to see if i have to use the password or the WEP key to get onto my wireless. But I found the solution to both of my problems.
    Hope this helped :apple::D
  8. tooly macrumors newbie

    Feb 11, 2011
    Iphone problem

    I had to input the encrypted key on the back of the router. It is a 10 digit number on my router enclosed in brackets. Hope this helps!!!
  9. Royal Raider macrumors newbie

    Mar 7, 2011
    Solution (worked for me)

    I've been having the exact same problem as described above ie. password is incorrect (even when you know you typed it in perfectly!) Anyway, I tried to log on to the wireless network and instead of entering the password I entered the modems address ie. http://???.???.?.? It was of course incorrect. Then I tried to log in again, entered the password and BOOM! IT WORKED! I've been unable to log on to this network for weeks even though others at work with iphones have no problem. Hope this helps.
  10. ddog1690 macrumors newbie

    Aug 7, 2011
    Rushmore is Right!!!

    Rushmore is right. The suggestion worked for me. Thanks!
  11. Jarrod1966 macrumors newbie

    Sep 7, 2011
    iPhone wi-fi password problem: WEP to WPA-PSK

    Here's a problem I had and the quick solution I found:

    My PC/laptop immediately accepted my wi-fi password at home and I was able to instantly start browsing. However, my iPhone did not. Instead of connecting to the wi-fi network, it showed an error stating 'unable to connect' - it rejected the password.

    After reading all the blogs about WEPs and WPAs and goodness knows what else (all mumbo-jumbo to me), I did the following;

    -accessed my router
    -selected WLAN
    -selected the password type 'WPA PSK' (not WEP)
    -entered a new password following the criteria specified for my 64 bit router (numbers between 0-9, letters a-f)
    -started the router again
    -started my iphone again worked first time

    Basically, my iPhone did not accept a password in WEP format whereas my computer did. The router gave me several options to try different password formats - WEP, WPA, WPA-PSK, etc.

    I tried the only format that only required a password with no other fiddling around with IP addresses.

    Hope this helps :)
  12. dragonflei macrumors newbie


    Sep 17, 2011
    This worked withot fail!

    Thank you!
    This fixed the Wi-Fi connectivity issue on my iPhone!
    The trick is to enter the modems address first> it will fail and ask for the password again> then enter the WPA/WEP passkey/password (what ever you use).
    It's like the manual reprogramming you would do to your cell phone if it couldn't pick up your carriers towers....
  13. nannymoo macrumors newbie

    Sep 26, 2011
    I fixed it myself!

    Thanks to the helpful hints in this thread, I decided to give it a whack on my own (no thanks to Charter)

    I pressed the button on the front of the modem that I thought might be "reset" but probably wasn't.

    Then I selected my network from the list and typed in the WPA-PSK from the modem label. Nobody in Charter had ever advised me to do that, but that is what connected me right away. :D
  14. Tdwroberts macrumors newbie

    Dec 15, 2011
    Can't connect to Wi-FI through phone

    I got my iphone last Thursday,it wouldn't connect to Wi-Fi, it would show the little icon that it as connected, but was not. My daughter and her husband both use their iphone 4's here, ( sometimes it takes a while), so we couldn't figure out the problem. Apple wouldn't help because they said it was a refurb, and out of warranty, AT&T said we had to call their warranty department,but the call wound get disconnected before anyone answered. They say (you have 30 or 60 days, to return ?) As an almost last resort, because I read that Apple/AT&T were swapping out phones, when this happened, (seems to be a big problem)but the new phones were not working either. So I tried jail break, my phone wouldn't except it (THANK GOD! ). So I went by daughter's yesterday and my Wi-Fi connected immediately to her Wi-Fi, so we determined it was the router, so I went and bought a new didn't work and Belkin Tech said it must be my computer ( which worked fine until I hooked up their router) needless to say MY S-I-L came over did an filmware upgrade on my old Linksys and EVERYTHING worked immediately !!! :p

Share This Page