Monaco Font suddenly displays faint and thin

Discussion in 'Mac Basics and Help' started by SqueegyX, Apr 4, 2008.

  1. SqueegyX macrumors regular

    Joined:
    Mar 24, 2008
    #1
    This is totally bizarre. I use Textmate and Terminal all day long. Textmate uses Monaco and Terminal uses Andale Mono.

    Yesterday, I figured out how to switch primary monitors. Dragging the little menu bar was not obvious in the displays panel, but thanks to a post here, I get to use my big external monitor as primary now rather than my MBP screen. All seemed fine.

    Today I notice that both Terminal and Textmate display their fonts far fainter and thinner than they used to. Like somehow the antialiasing mode in photoshop got changed form strong to crisp or something.

    Xcode seems affected too. The rest of the system looks fine, but it seems Terminal and Code editors (mono spaced fonts only maybe?) are universally affected.

    I assume this is somehow due to the primary monitor switch because that is really the only thing that changed. Switching the primary monitor back has no effect. This issue may seem minor, but it seriously hampers my ability to read my own code. It's driving me crazy.

    10.5.2

    [EDIT] Also changing the "System Preferences > Appearance > Font smoothing style" to different options seems to have zero effect on my text. Its like this option is suddenly being ignored? The "Turn off text smoothing for for font sizes X and smaller" option seems to work fine however.
     
  2. kelvinj macrumors newbie

    Joined:
    Jun 26, 2008
    #2
    Not sure if you've already solved this but I was having the same problem and I have been able to fix it. It seems like this happens when mac os thinks your connected external monitor is a CRT and switches the automatic font-smoothing in the Appearance pref frame to "light."

    I changed this to "Medium - best for Flat Panel" and then restarted Textmate, and it worked!

    Hope that helps.
     

Share This Page