Monitors dead x 2

Discussion in 'Mac Basics and Help' started by Haratio, Jun 28, 2007.

  1. Haratio macrumors newbie

    Joined:
    Jun 28, 2007
    #1
    We are the happy recipients of PowerMac G3 + sundry peripherals from my son's school. My son has worked with this computer for quite a while and it has always worked fine.

    When hooked up to a "new" monitor (Apple performa+ Display)it worked for a few hours. Next morning, wouldn't work. :(

    When hooked up to another "new" monitor (Macintosh Color Display) it also worked fine for a few hours, and then went to meet it's maker. :( :(

    We are perplexed ...I'm now reluctant to try with any other monitors until I have some idea of what's going on. Problem doesn't seem to be with the computer...makes the usual noises on startup, though there is a new grunt/clank noise on boot..

    Any help is much appreciated!
    Haratio
     
  2. Killyp macrumors 68040

    Killyp

    Joined:
    Jun 14, 2006
    #2
    I work with a lot of older TV sets, and it just sounds to me like you're a victim of CRT displays decaying. What tends to happen, is that a CRT will sit in one place for ages, never get used and work reliably for all that time. However, you move it and all of a sudden, boomf it's gone.

    When you say 'they don't work', do you mean they don't power up at all, or they don't wake up when you switch on the computer?
     
  3. Haratio thread starter macrumors newbie

    Joined:
    Jun 28, 2007
    #3
    When I turn it on, the light on the monitor goes on, but the screen is still blank.
     

Share This Page