Monstor Drive

Discussion in 'Mac Accessories' started by mrderisory, Jun 23, 2006.

  1. mrderisory macrumors member

    Dec 19, 2004
    I bought a 4gb Monstor Drive from Radio Shack today, and I got this thing home and I cant get it to work. I am not sure if I am doing something wrong, if it doesn't support macs, or if its a piece of garbage.

    I have a Powerbook G4 1 gig, OS X Tiger.

    I tried plugging it into the computer straight and tried using the cord it came with. Neither seem to bring it up...

    It came with a mini disc but I am sure my powerbook can read those?
  2. iGary Guest


    May 26, 2004
    Randy's House
    Go to Disk Utility and see if you can manually mount it...
  3. mrderisory thread starter macrumors member

    Dec 19, 2004
    Hmm I tried this and it says Gathering Disk Information... forever and it never stops "gathering"

    I am correct that my powerbook cannot read a mini disc?

    I hope im not screwed the radio shack was going out of business here and they said all sales were final..... :-/
  4. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
    Google says Monstor Drives are Mac compatible... Mini Disks? I assumed Monstors are USB Flash drives?
  5. mrderisory thread starter macrumors member

    Dec 19, 2004
    You are right its a flash driver. When I say mini disc it came with a tiny mini disc that says USB drive. I cant fathom why I'd need it. I didnt need a disc to install my router, ipod, modem, etc.

    When I plug my ipod into the usb port it pops up on my desktop and I go from there. When I plug this thing in its not doing anything. The light, lights up green on it but it never does anything or appears on mydesktop nada.
  6. mrderisory thread starter macrumors member

    Dec 19, 2004
    Ok we got a new a problem now my Ipod isnt working when i Connnect it to my USB drive it beeps beeps beeps beeps beeps and it showed up on my desktop for a brief second then it said REMOVAL! Warning ANY UNSAVED DATA LOST.......

    Thing is it wasnt removed. WTF is going on?
  7. solvs macrumors 603


    Jun 25, 2002
    LaLaLand, CA
    Bad USB port? Try another one. Restart first maybe, then plug it in. See what happens. Don't put the mini disk in.
  8. Fleetwood Mac macrumors 65816

    Fleetwood Mac

    Apr 27, 2006
    Two separate problems.

    Your iPod battery is dead (completey), charge it. Don't unplug it from your PowerBook for an hour no matter what it does. Don't try to start it up.

    Your Monster is garbage, but you might be able to get it to work. Open 'er up in the Disk Utility and see if you can format it. I heard this works-sometimes, otherwise you can use it on a PC. :rolleyes:

Share This Page