Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

mrcj.

macrumors newbie
Original poster
Oct 26, 2021
6
6

Attachments

  • Screen Shot 2021-10-26 at 14.48.00.png
    Screen Shot 2021-10-26 at 14.48.00.png
    445.4 KB · Views: 1,680

edobld

macrumors newbie
Oct 28, 2021
1
1
Yes, definitely a bug as that toggle should be there. I'm trying to do the opposite: I do want that my Mac goes to sleep without manually turning off my Bluetooth devices, and it seems I have to resort to some script to manually disable Bluetooth before putting the machine to sleep.
 
  • Like
Reactions: arobert3434

ctg7w6

macrumors 6502
Oct 23, 2014
404
738
Yes, definitely a bug as that toggle should be there. I'm trying to do the opposite: I do want that my Mac goes to sleep without manually turning off my Bluetooth devices, and it seems I have to resort to some script to manually disable Bluetooth before putting the machine to sleep.
Yep, same problem here. My computer won't go to sleep because my bluetooth mouse and keyboard keep waking it up (I am not touching them or anything).

Why remove the toggle, Apple? Like, of all the petty, ridiculous things to do.
 

alphascorp

macrumors 6502
Jul 16, 2018
298
535
Brest, France
Hi all,

Same here

I didn't have this option in all the Beta versions and I thought it would be there in the final version but no.
 

Attachments

  • Capture d’écran 2021-10-27 à 21.35.01.png
    Capture d’écran 2021-10-27 à 21.35.01.png
    164.3 KB · Views: 462

ARMunix

macrumors newbie
Mar 25, 2021
14
1
Yes, definitely a bug as that toggle should be there. I'm trying to do the opposite: I do want that my Mac goes to sleep without manually turning off my Bluetooth devices, and it seems I have to resort to some script to manually disable Bluetooth before putting the machine to sleep.
Currently having the same problem, apparently my Logitech MX Ergo keeps waking my M1 Mac mini when it's connected via BT. Never occurred with Big Sur.
 

iMactouch

macrumors member
Mar 22, 2017
43
15
Wunstorf, Germany
I hope that this is a bug and not intended behaviour.

It is really sad that my Mac Pro 2013 now wakes up every time someone touches the table which seems to move the MX Vertical mouse!
 

ctg7w6

macrumors 6502
Oct 23, 2014
404
738
I commented above, but just to give my information, the devices waking up my MacBook Pro (2020, intel) are my Logitech mx master 3 (Mac version) and mx keys (Mac version) keyboard. They are the only bluetooth devices I have connected (though my AirPods Pro and AirPods Max bluetooth profiles are on the computer, they are never really actually connected to my Mac).
 

ctg7w6

macrumors 6502
Oct 23, 2014
404
738
Mac Pro 2013 are: MX Vertical, MX Keys for Mac and the original Apple Touchpad 2.
That has never been the case the last 15 years!
Just a little update. I had the "Logi Options" software installed with my devices. I uninstalled it and opted-in to the beta of "Logi Options+". I don't like using beta software, but SO FAR it restored proper functionality to my devices and has stopped the refusal to sleep. (FYI, the scrolling wheel would stop working randomly and only a computer restart would fix it).

I will keep you guys updated if this solution does not work. I still think its an Apple issue, but maybe not, it seems like a lot of the issues here are with Logitech.
 

iMactouch

macrumors member
Mar 22, 2017
43
15
Wunstorf, Germany
I uninstalled it and opted-in to the beta of "Logi Options+".
I am using both Logi Options (for MX Vertical) and Logi Options+ (for MX Keys for Mac) since a long time without any problem.
The sleep problem is only an Apple problem, as the function for not letting Bluetooth devices wake up the Mac is killed!
My Mac Pro goes to sleep ans stays in sleep mode, but only a small movement of the MX Vertical wakes it up.
 

tonyr6

macrumors 68000
Oct 13, 2011
1,638
588
Brooklyn NY
Now I know why my MacBook has been warm draining the battery when not in use. I had this problem until I disabled wake devices on Bluetooth. Now realizing that the option is missing is the reason why my MacBook is warm most of the time. I have to shut it down when not in use.
 

tonyr6

macrumors 68000
Oct 13, 2011
1,638
588
Brooklyn NY
Turing off Bluetooth before putting the MacBook to sleep it says sleep. I only had 1% battery drain overnight. All I connect wireless is my mouse. Speakers I wire as Bluetooth is unreliable. I just turn on Bluetooth before using the mouse.
 

ctg7w6

macrumors 6502
Oct 23, 2014
404
738
Turing off Bluetooth before putting the MacBook to sleep it says sleep. I only had 1% battery drain overnight. All I connect wireless is my mouse. Speakers I wire as Bluetooth is unreliable. I just turn on Bluetooth before using the mouse.
This is what I had been doing as well--turning off bluetooth before putting it to sleep. It worked, the Mac stayed asleep.
 

tonyr6

macrumors 68000
Oct 13, 2011
1,638
588
Brooklyn NY
Did not work. Just woke up my laptop and its hot in the case. This is with Bluetooth off. My battery was 66% now 38%. It all started with Monterey. Never had this problem with Big Sur.
 

stevenaaus

macrumors member
Oct 23, 2013
53
38
Sorry to hijack thread, but I just installled Mojave on my 2012 Pro, and it keeps waking up for goodness knows why. I've unchecked the 'Bluetooth wakeup' box, but dang it still keeps powering up at all time. (&^$# :(
 
  • Like
Reactions: tonyr6

mrcj.

macrumors newbie
Original poster
Oct 26, 2021
6
6
Sorry to hijack thread, but I just installled Mojave on my 2012 Pro, and it keeps waking up for goodness knows why. I've unchecked the 'Bluetooth wakeup' box, but dang it still keeps powering up at all time. (&^$# :(
Try this on terminal.⬇️⬇️⬇️

pmset -g log | grep -i "wake from"
 
  • Like
Reactions: adib

tonyr6

macrumors 68000
Oct 13, 2011
1,638
588
Brooklyn NY
Went to sleep with about 50% battery woke up to an dead battery icon. I should have never upgraded. Now I am going to have to shutdown the laptop when not in use.

Did all the usual boilerplate fixes which never work like resetting the SMC, PRAM or whatever and making sure the vents are clean. I wonder if I can replace this with an late 2020 M1 Macbook Air.
 
Last edited:

stevenaaus

macrumors member
Oct 23, 2013
53
38
Try this on terminal.⬇️⬇️⬇️

pmset -g log | grep -i "wake from"
Thanks mate... that might help me find the issue.
The offending line seems to be "Darkwake from normal sleep [cdn] due to EC.SleepTime: Using AC"
I'll try the "pmset -b tcpkeepalive 0" fix.
...This will result in some critical feature like 'Find My Mac' not to function.
Gah! Thats what i love about the tech industry and macOS especially. Just pile on the new arcane features and don't worry about what you break. Hell - it's not as if the users actually pay for the OS anyway.
 

marcpeiron

macrumors newbie
Nov 12, 2021
1
0
Hi! I just bought a new 14" Macbook Pro and I want to use it with an external display, while turning down the computer's display. When I do it, it goes to sleep and I can't wake it up by moving or pressing the mouse/keyboard. According to this treat, Do I have to wait for Apple to bring back the advanced bluetooth tab or is there another way to do it? Thanks!
 

TV4Fun

macrumors newbie
Nov 12, 2021
1
3
Having the same issue and extremely annoyed by it. According to this support ticket, you can disable wake on Bluetooth from the command line with the command
Code:
/usr/bin/defaults write /Users/`whoami`/Library/Preferences/ByHost/com.apple.Bluetooth.`/usr/sbin/system_profiler SPHardwareDataType | /usr/bin/grep "Hardware UUID" | /usr/bin/cut -c22-57`.plist RemoteWakeEnabled 0
Replace the 0 with a 1 if you want to enable it. I don't know if this still works for Monterey though. Will let you know.

Update: I'm not sure if it was this or installing Logi Options+ (I did both at the same time), but after running this command to enable wake on bluetooth, I can now bring my Macbook out of sleep mode with my bluetooth mouse.
 
Last edited:

ctg7w6

macrumors 6502
Oct 23, 2014
404
738
Having the same issue and extremely annoyed by it. According to this support ticket, you can disable wake on Bluetooth from the command line with the command
Code:
/usr/bin/defaults write /Users/`whoami`/Library/Preferences/ByHost/com.apple.Bluetooth.`/usr/sbin/system_profiler SPHardwareDataType | /usr/bin/grep "Hardware UUID" | /usr/bin/cut -c22-57`.plist RemoteWakeEnabled 0
Replace the 0 with a 1 if you want to enable it. I don't know if this still works for Monterey though. Will let you know.

Update: I'm not sure if it was this or installing Logi Options+ (I did both at the same time), but after running this command to enable wake on bluetooth, I can now bring my Macbook out of sleep mode with my bluetooth mouse.
If you see my post above, I installed Logi Options+, the new beta software and it fixed all of my problems and I can wake my Macbook with my bluetooth mouse as well.
 

Simos.805

macrumors newbie
Apr 15, 2017
29
22
Athens, Greece
I have the same issue. Until Monterey, I hade disabled the option to wake the computer through Bluetooth devices, because I don't want my Magic Keyboard or Magic Mouse to wake my iMac every time I hit a key or move the mouse by mistake, I just want to press the power button behind my iMac if I want to wake it.

Now with Monterey, that option disappeared and every time I hit a key on the keyboard or move the mouse, my iMac wakes up! So annoying...
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.