Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Simos.805

macrumors member
Apr 15, 2017
35
24
Athens, Greece
Having the same issue and extremely annoyed by it. According to this support ticket, you can disable wake on Bluetooth from the command line with the command
Code:
/usr/bin/defaults write /Users/`whoami`/Library/Preferences/ByHost/com.apple.Bluetooth.`/usr/sbin/system_profiler SPHardwareDataType | /usr/bin/grep "Hardware UUID" | /usr/bin/cut -c22-57`.plist RemoteWakeEnabled 0
Replace the 0 with a 1 if you want to enable it. I don't know if this still works for Monterey though. Will let you know.

Update: I'm not sure if it was this or installing Logi Options+ (I did both at the same time), but after running this command to enable wake on bluetooth, I can now bring my Macbook out of sleep mode with my bluetooth mouse.
I run the command but my iMac still wakes up from my Magic Keyboard and Magic Mouse.
 

aviegas

macrumors member
Jul 12, 2019
64
6
localhost.localdomain
My 2018 Mac mini was not properly sleeping:it would not enter sleep mode by itself or would return in less than a minute if forced into sleep manually.

I'm using a Logitech Bluetooth MX anywhere 3 and a Keychron Bluetooth keyboard.

I've read the whole thread and noticed the comment on the Logitech Options as one possible source. After removing it, so far it seems to be working.

It seems that Logitech option is either waking up the system on its own or leaving the mouse too sensitive that any movement of the table causes the wakeup.
 

mrcj.

macrumors newbie
Original poster
Oct 26, 2021
6
6
updated to 12.1 and option is still missing.

wtf apple ?
 

Attachments

  • mac-wont-go-to-sleep-mode-how-to-fix-it-tested-solutions-4.jpg
    mac-wont-go-to-sleep-mode-how-to-fix-it-tested-solutions-4.jpg
    154.3 KB · Views: 463
  • Like
Reactions: Quackers

aviegas

macrumors member
Jul 12, 2019
64
6
localhost.localdomain
Are you using any Logitech software or drivers? Getting rid of the Logitech mouse software solved my problems.

And on Monterey I'm no longer having mouse (Logitech MX Anywhere) + keyboard (Keychron) problems.
 

jerimy

macrumors newbie
Jul 14, 2016
2
0
If you see my post above, I installed Logi Options+, the new beta software and it fixed all of my problems and I can wake my Macbook with my bluetooth mouse as well.
Thanks for the info. Also, I just installed Logi Options+ Beta (last night) as well, in the hopes it might fix something, and it seems to have fixed all my sleep wake issues on Monterey.
 
Last edited:

qpid360

macrumors 6502a
Apr 23, 2009
526
90
Pasadena, CA
This seems to have started happening to me on 12.2 RC and the final public release. Battery completely dies overnight unless I either turn off the Magic Mouse and keyboard or remove them from my list of bluetooth devices. What a pain. Is there an actual fix for this?
 

random-uk

macrumors member
Dec 29, 2011
54
16
Same for me - not had the problem in 12.1 and am now having the issue with a magic trackpad 2. I try and put my mac to sleep and it just keeps waking up.

If you do: pmset -g log | grep -i "wake from" you'll see a load of DarkWake bluetooth related things.

I've tested this with 3 different magic trackpads, in safe mode and it continues to happen. If you plug the magic trackpad in via usb the errant wake behaviour stops. Also, if you turn off bluetooth prior to putting to sleep, the wake behaviour stops.

So as a horrid hacky workaround:
Using a combination of Hammerspoon and blueutil (available on brew) I've automated turning bluetooth off at sleep and on at wake via the hs.caffeinate.watcher.systemWillSleep and hs.caffeinate.watcher.systemDidWake.

Obviously it would be much nicer if Apple fixes this bizarre bug but until then thought this approach might help others.
 

qpid360

macrumors 6502a
Apr 23, 2009
526
90
Pasadena, CA
Same for me - not had the problem in 12.1 and am now having the issue with a magic trackpad 2. I try and put my mac to sleep and it just keeps waking up.

If you do: pmset -g log | grep -i "wake from" you'll see a load of DarkWake bluetooth related things.

I've tested this with 3 different magic trackpads, in safe mode and it continues to happen. If you plug the magic trackpad in via usb the errant wake behaviour stops. Also, if you turn off bluetooth prior to putting to sleep, the wake behaviour stops.

So as a horrid hacky workaround:
Using a combination of Hammerspoon and blueutil (available on brew) I've automated turning bluetooth off at sleep and on at wake via the hs.caffeinate.watcher.systemWillSleep and hs.caffeinate.watcher.systemDidWake.

Obviously it would be much nicer if Apple fixes this bizarre bug but until then thought this approach might help others.
Yep the logs show it waking every 6 seconds from Bluetooth until the battery dies ?‍♂️
 
  • Sad
Reactions: HeroOfTime32

vitamanic

macrumors member
Jul 25, 2020
33
16
After the update to 12.2 today I'm getting wakes every 60 seconds on my Intel 16 MBP which seemingly doesn't let the notebook actually enter a sleep state, even for a minute.

This is what it looks like in terminal:

2022-01-27 21:19:04 -0500 DarkWake DarkWake from Deep Idle [CDNP] : due to EC.Bluetooth/Maintenance Using AC (Charge:79%) 31 secs

Sometimes I'll see this instead of the above every 5 minutes:

2022-01-27 18:56:47 -0500 Wake Wake from Deep Idle [CDNVA] : due to EC.Bluetooth/HID Activity Using AC (Charge:80%) 320 secs

At this point I guess I'm forced to roll back to 12.1 with TM. Kinda wild that this made it to release.
 

Sheppardhazemaze

macrumors newbie
Jan 28, 2022
3
0
Nice to see, that I'm not alone with the problem. Whenever I turn off my bluetooth, it actually goes to sleep. The funny thing is, that there isn't even a connection necessary: When I turn off all my bluetooth devices (even the ones that are not connected), my Mac will not go to sleep...
so annoying.

And in general I still have bluetooth troubles (M1 Air): My Trackpad never worked fluently, I only use it with the USB Connection. They really must be messing around with the bluetooth stuff right now...
 

bogdanw

macrumors 68030
Mar 10, 2009
2,611
1,237
Installed macOS 12.2 on my iMac 5K 2017 and the problem is still there.
You can try with
Code:
sudo defaults write ~/Library/Preferences/ByHost/com.apple.Bluetooth.*.plist RemoteWakeEnabled -bool NO; sudo killall bluetoothd
 

random-uk

macrumors member
Dec 29, 2011
54
16
You can try with
Code:
sudo defaults write ~/Library/Preferences/ByHost/com.apple.Bluetooth.*.plist RemoteWakeEnabled -bool NO; sudo killall bluetoothd
Thanks for that idea, but tried it here and I'm still seeing the issue. The only thing that's kinda working is turning off bluetooth before I sleep my mac :(

Has anyone had success with the approach?
 

zisoft

macrumors newbie
Dec 18, 2020
2
2
Same here, tried that too, but to no avail:

2022-01-29 22:22:01 +0100 Wake Wake from Deep Idle [CDNVA] : due to EC.Bluetooth/HID Activity Using BATT (Charge:89%) 32 secs
 

J1immyS

macrumors newbie
Mar 2, 2021
3
0
After the update to 12.2 today I'm getting wakes every 60 seconds on my Intel 16 MBP which seemingly doesn't let the notebook actually enter a sleep state, even for a minute.

This is what it looks like in terminal:

2022-01-27 21:19:04 -0500 DarkWake DarkWake from Deep Idle [CDNP] : due to EC.Bluetooth/Maintenance Using AC (Charge:79%) 31 secs

Sometimes I'll see this instead of the above every 5 minutes:

2022-01-27 18:56:47 -0500 Wake Wake from Deep Idle [CDNVA] : due to EC.Bluetooth/HID Activity Using AC (Charge:80%) 320 secs

At this point I guess I'm forced to roll back to 12.1 with TM. Kinda wild that this made it to release.
My 27" 2020 iMac behaves in a similar fashion, one sleep/wake cycle per a minute or so - this is crazy!

DarkWake from Normal Sleep [CDN] : due to EC.Bluetooth/Maintenance Using AC (Charge:0%) 45 secs
 

bogdanw

macrumors 68030
Mar 10, 2009
2,611
1,237
Thanks I’ll try it.
Can you tell me what this is supposed to do?
The first part sets RemoteWakeEnabled to NO, corresponding to disabling the “Allow Bluetooth devices to wake this computer” from the Advanced tab.
The second part terminates the bluetoothd process. It will restart by itself.
 

heyRob

macrumors newbie
Jun 14, 2019
3
2
I have the same issue on my Intel MBP 2018. I use Magic Keyboard + Trackpad and
pmset -g log | grep -i "wake from"
is reporting the mentioned DarkWakes until the battery is fully drained. Will try turning off bluetooth for now.
 

HeroOfTime32

macrumors member
Apr 7, 2012
37
57
Florida
Until this finally gets fixed (hopefully) by Apple…is a temporary fix just manually turning off Bluetooth before closing and sleeping the machine? Then turning it back on when you’re working again? Just want to make sure that is a viable solution in the interim.
 

random-uk

macrumors member
Dec 29, 2011
54
16
Until this finally gets fixed (hopefully) by Apple…is a temporary fix just manually turning off Bluetooth before closing and sleeping the machine? Then turning it back on when you’re working again? Just want to make sure that is a viable solution in the interim.
Yes that's the workaround I'm using. Irritating but better than having zero battery in the morning.
 
  • Like
Reactions: HeroOfTime32

kapitainsky

macrumors member
Dec 30, 2020
32
17
Same for me - not had the problem in 12.1 and am now having the issue with a magic trackpad 2. I try and put my mac to sleep and it just keeps waking up.

If you do: pmset -g log | grep -i "wake from" you'll see a load of DarkWake bluetooth related things.

I've tested this with 3 different magic trackpads, in safe mode and it continues to happen. If you plug the magic trackpad in via usb the errant wake behaviour stops. Also, if you turn off bluetooth prior to putting to sleep, the wake behaviour stops.

So as a horrid hacky workaround:
Using a combination of Hammerspoon and blueutil (available on brew) I've automated turning bluetooth off at sleep and on at wake via the hs.caffeinate.watcher.systemWillSleep and hs.caffeinate.watcher.systemDidWake.

Obviously it would be much nicer if Apple fixes this bizarre bug but until then thought this approach might help others.
The same problem here and I am only using Apple magic mouse. Turning BT off indeed works but automation is always better - would you mind to share you Hammerspoon script? I have also achieved the same using sleepwatcher - all details in the next post.
 
Last edited:

kapitainsky

macrumors member
Dec 30, 2020
32
17
In my case it happens when on battery or on AC power - and if I have external disk connected it starts/stops every few seconds. Not acceptable. And of course when on battery it kills it quick.

Turning BT manually off before going sleep "fixes" the problem but automation is always better in case like this.

Until apple fixes it here is my workaround - it switches BT off when going sleep and back on when waking up.

Using brew install sleepwatcher and blueutil:
Code:
brew install sleepwatcher && brew install blueutil

Create .sleep and .wakeup scripts' files in your home folder:
Code:
echo "/usr/local/bin/blueutil -p 0" > ~/.sleep && echo "/usr/local/bin/blueutil -p 1" > ~/.wakeup
When on ARM mac check before where blueutil tool is (which blueutil). I think brew moved default instalations directory from /usr to /opt

Make both files excecutable:
Code:
chmod 755 ~/.sleep && chmod 755 ~/.wakeup

Restart sleepwatcher service:
Code:
brew services restart sleepwatcher

Now when your computer goes sleep BT is turned off and restored when it wakes up.


When Apple fixes this issue you can simply remove .sleep and .wakeup files and/or uninstall sleepwatcher and/or blueutil:
Code:
rm ~/.sleep && rm ~/.wakeup
brew uninstall sleepwatcher && brew uninstall blueutil

and cleanup services to get rid off any residue:
Code:
brew services cleanup
 
Last edited:

rs-mac

macrumors member
Sep 29, 2021
31
40
Filed bug (FB9864403). This appears to be a regression in macOS. Very similar DarkWake issue after the 10.13.4 update (which Apple finally fixed in 10.14).

In my case, iMac Pro with Apple's BT keyboard and magic mouse. Three LaCie RAIDs connected to a single Thunderbolt 3 port. The iMac will sleep its display, the RAIDs begin to sleep, but then immediately wake, then sleep, wake, etc. indefinitely.

Workaround is to do a complete system shutdown overnight rather than sleeping. Thankfully the iMac Pro cold boot is very fast (about 30 to 40 seconds).
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.