Mophie Juice Air Pack Not Working on My iPhone4

Discussion in 'iPhone Accessories' started by eplayz, Feb 22, 2011.

  1. eplayz macrumors newbie

    Joined:
    Feb 22, 2011
    #1
    Hi! I am a new member to the forums.

    I recently bought a Mophie Juice Air pack for my iphone 4. After the first time I fully charged the pack, a few hours into the day I decided to see if I had a full charge by checking out my LED's. To my surprise none of them came on! I tried switching the standby switch on and off, nothing happened. When I got home from work, I plugged it back in and instantly all four LED's lit up! I proceeded to unplug it and it worked from then on. I figured it was a fluke and disregarded it. But the same thing just happened again. This is getting frustrating. I have searched the forums to see if anyone else had this problem but couldn't find anything, unless I am searching incorrectly.

    I was wondering if anyone has had the same problem and can help me out, or did I just get a bad case.
     
  2. studmule macrumors regular

    Joined:
    Aug 29, 2010
    #2
    You may need to shoot Mophie an email. Their customer service is excellent. I had a problem with my juice pack air, and they emailed me a UPS label to send it back, and they replaced it pretty quickly.
     
  3. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #3
    That's a bummer. Definitely call them.

    I just got my Verizon/universal iPhone 4 juice pack air today. So far I'm impressed. It's not going to get daily use, but for when I'm on business trips and away from a charger for long periods of time. I tend to be pretty hard on my phone when I'm away on business. The iPad's 10 HR battery has been a godsend compared to my laptop. Now I just need my phone to keep up (and with the Mophie it should).
     
  4. weisjt macrumors 6502a

    weisjt

    Joined:
    Dec 8, 2010
    Location:
    Southern Pines, North Carolina
    #4
    haha yeah the forum i dont think is going to fix your case just return for a new one.
     
  5. mophienick macrumors newbie

    Joined:
    Mar 2, 2011
    Location:
    San Diego, CA
    #5
    Mophie Support

    Sorry you're having a problem. This is a unique issue, so it sounds like you have a defective unit.

    Just go to this page and submit the form, our star customer service team will take care of you right away:

    http://www.mophie.com/articles.asp?id=153
     
  6. TominDC macrumors newbie

    Joined:
    Aug 7, 2013
    #6
    If like me you run across this same issue and can't return the item bc you not longer have the receipt this may help. Looks like the issue is that one or both of the wires from the battery to the board has come off. This most likely will void your warranty and may not work for you, so if you do do it do it at your own risk....

    I ended up cracking open the case, it's not too hard. Remove the outter plastic piece that goes around the bottom half of the case. Mine was grey. I used a push pin to loosen the glue that was holding it on. Careful taking off this off around where the USB port is, can break easily. Once that's off separate the the back part of the case from the inside half that holds the battery, used the same push pin. You should now have a two parts, one that has the battery and board with the lights and the other back part. Make sure to not loose the on/off rocker switch. Solder the wire back and you should be in business...

    Worked for me hope it works for you...

    Here's a couple pics showing me taking it apart:

    [​IMG]

    [​IMG]
     

Share This Page