More Early '11 13" i7 SSD issues/questions

Discussion in 'MacBook Pro' started by rx7ah, Apr 14, 2012.

  1. rx7ah macrumors newbie

    Joined:
    Apr 14, 2012
    #1
    Hi guys. I feel bad about posting because I know people have had the same problem. However, I've read through probably 100 different articles on this issue and none has had a solution that worked for me.

    My Specs
    I have the Early 2011 13" 2.7GHz i7 MacBook Pro. Model: A1278. I have upgraded the ram from 4GB to 8GB and have installed a Kingston 128GB SSD.

    The General Problem
    I know that there have been many issues with the early '11 MBPs and SSD compatibility. What the issue that I've read about nearly everywhere and am, myself, experiencing, is that using a non Apple brand or (some) Intel solid state drives will result in spotty reading, almost nonfunctional writing, and overall a very large array of issues that make the drive inoperable. From my understanding, this is effects both the SATA connection for the designated HDD slot and the optical bay. My specific problem is for the designated HDD slot - making it the sole drive in my laptop.

    The Provided Solution
    Everything that I've read says that Apple released a firmware update that will resolve these SATA III SSD issues that have pretty much prevented the use of an SSD that didn't come from Apple. It allows ANY SATA II or III SSD to be used and work completely wth the early '11 MacBook Pros.

    My Sepcific Problem
    Whie this sounds fantastic, I haven't had it work for me. I've tried five completely different drives (listed below) and only one has worked.
    - Corsair Force 3 120GB
    - Patriot Pyro 120GB
    - OC Z Agility 3 120GB
    - Intel SATA III 120GB

    - Kingston SV100S2128G (the only drive I have gotten to work)
    - SanDisk Extreme 240GB SATA III

    That is in the order in which they were tested. The first somewhere around September '11 (before the firmware update). The SanDisk was tried just yesterday. I have downloaded and applied all updates for my MacBook Pro (model number: A1278). I chose the SanDisk drive because every review I've read said it had stellar speeds AND I saw at least a dozen MacBook Pro users that said it worked flawlessly. Two of those users were early 2011 as well, but the i5 processor.

    The Question
    Well, obviously I'm here for help. What can I do? What drive is confirmed to work in this model? I don't want to just buy and return drives every day until I find a 240/256GB that works (that is the reason for this upgrade from the Kingston that is currently working). I would buy a larger Kingston, but if SATA III is supposed to work, I would like to get a SATA III drive. They are also incredibly expensive compared to many other drives of the same specs. I hope you guys have a suggestion for me.


    I was looking at this Intel SSD. Is there anything I need to know, check, or do before trying, once again, to get a bigger drive?
     
  2. lamboman macrumors 6502

    Joined:
    Aug 13, 2011
    #2
    You haven't stated exactly how these drives haven't worked, nor have you stated the specific Intel drive that you purchased before.

    Apart from the Intel (as it's unknown, though it could be a 510 or 520), all of the drives that you have purchased that have not worked have been Sandforce SF-2281 based.

    Now I'm not saying that is the issue, but it could very well be that for some really bizarre reason that this is causing the drives to play nasty.

    The 520 is another Sandforce SF-2281 drive. You might want to try a Crucial m4 instead, but we'll need more information before we can suggest anything.
     

Share This Page