More iMessages/FaceTime Activation Issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by nd16x, Mar 12, 2012.

  1. nd16x macrumors newbie

    Joined:
    Jul 30, 2011
    #1
    Let me preface this post by stating that I've spent a good three hours reading various forums about issues people are having with iMessages. I also called my carrier, who said that they couldn't help me and that I should call Apple. When I called Apple they said that since I purchased my iPhone 4 close to a year ago they would be able to assist me unless I paid about $79 for AppleCare. I understand their position, so I can't really blame them.

    Here is my issue. I've always been on a stock phone and never jailbroken my iPhone. About a month ago a friend told me that my iMessages caller ID showed my email even though I had my number as my caller ID. I went into the messages setting and noticed something unusual... Usually, you have any emails you wanted to link to iMessages as well as your number. However, my number did not appear.

    Yesterday, I thought I'd do a restore and set up my iPhone as a new phone - so I didn't restore from a backup. I was hoping this would fix the issue. Now, I can't seem to activate iMessages or FaceTime.

    As I said, I've spent a fair amount of time reading various forums on possible fixes and tried them all, to no avail.

    I decided to go down to an Apple store to see if they could fix the issue and even they couldn't fix it. I'm hesitant to pay the extra $70 for AppleCare to get technical support over the phone now, after seeing that the employees at the Apple Store were not able to fix it.

    Anyone have any tips at all?

    I can live without FaceTime and iMessages, but it just bugs the hell out of me not knowing what the issue is.

    Thanks in advance.
     
  2. frag2 macrumors member

    Joined:
    Sep 23, 2009
    #2
    try disabling imessage. reboot phone. then enable imessage

    my friend had that problem adn it seem to work
     
  3. nd16x thread starter macrumors newbie

    Joined:
    Jul 30, 2011
    #3
    Thanks for the suggestion. I tried that before and it didn't fix the issue. When I went to Apple they had two people trying to figure out what was wrong for over half and hour and still no go...
     

Share This Page