More than one 'supposed' partitions, installing Windows 7 - bootcamp

Discussion in 'MacBook Pro' started by ecerra, Oct 27, 2011.

  1. ecerra macrumors newbie

    Joined:
    Oct 27, 2011
    #1
    I am trying to install Windows 7 using boot camp assitant but it keeps telling me that "the startup disk must be formatted as a single Mac OS Extended (Journaled) volume or already partitioned by Boot Camp Assistant for installing Windows" and the only partitions is the "Macintosh HD" and "Recovery HD". If it helps I deleted a Ubuntu partition very recently.

    I am running Lion.
     
  2. torid110 macrumors regular

    Joined:
    Jan 22, 2006
    Location:
    Jersey City, NJ
    #2
    After you deleted the Ubuntu partition, did you resize the OSX partition to use the space that was left ?
     
  3. ecerra thread starter macrumors newbie

    Joined:
    Oct 27, 2011
  4. ecerra thread starter macrumors newbie

    Joined:
    Oct 27, 2011
  5. zaxdude macrumors regular

    Joined:
    Mar 11, 2011
    #6
  6. MacsAreBetter\ macrumors member

    MacsAreBetter\

    Joined:
    Jan 15, 2010
    Location:
    Gold Coast, Australia
    #7
    Try repairing your disk through Disk Utility. Then try permissions. Good luck!
     
  7. ecerra thread starter macrumors newbie

    Joined:
    Oct 27, 2011
    #8

    Yeah for some reason I can't get passed the first page of the Boot Camp Assistant.

    ----------

    I've done that like 5 times from the actual OS and also from the Recovery Partition and from the USB Recovery Disk I made.
     
  8. xDC macrumors member

    Joined:
    Jul 7, 2010
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I had the same issue, the only fix was to back up with time machine, erase the disk (which was done right before when I had fresh installed lion) but when I reformatted again and restored with time machine it worked
     
  9. ecerra thread starter macrumors newbie

    Joined:
    Oct 27, 2011
    #10

    Did you reformat the drive from the normal Recovery Partition or from a USB Recovery Drive?
     

Share This Page