Most efficient OS X for MacBook Air 2,1

Discussion in 'MacBook Air' started by Cave Man, Feb 25, 2017.

  1. Cave Man macrumors 604

    Cave Man

    #1
    I have an old MacBook Air 2,1 (2 GB RAM, 120 GB SSD, 1.8 gHz Core 2 Duo) that runs dead-dog slow and fan perpetually running with Yosemite, so I am going to wipe the drive, partition it in two, install Ubuntu on one partition and OS X on the other. My inclination is to install Snow Leopard as it seems this is the consensus for OS X efficiency on this model. So, opinions on other OS X versions for this particular MBA?

    TIA!
     
  2. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #2
    I'd say SL is probably your best bet. Mavericks as a second, but it would still be a whole lot slower and get your fans up high, but it would be a lot kinder to your memory and GPU than Yosemite
     
  3. Cave Man thread starter macrumors 604

    Cave Man

    #3
    OK, I installed SL and the computer runs quietly. The only issue I've found so far is that when I launch iTunes (most current version) I get an error message about some "Tea" plugin that can't be used. I have no idea where this plugin is so I can't get rid of it. It's not in ~/Library/Audio/Plug-ins. It must have come over when I did Migration Assistant from my MacBook. It sure is annoying.

    However, Ubuntu was a pain in the backside to get installed (16.04). After installing the rEFind boot loader my 8 GB USB thumb drive simply wouldn't boot. I created one multiple times using unetbootin but each time it failed. I have no idea what I did differently to finally get it to boot; the thumb drive is initialized as FAT32 and GUID partition table. Anyway, I had to boot using the "Try Ubuntu without Installing" option (probably should have done this sooner) because booting from the "Install Ubuntu" failed with a boot error. Once booted into the "Try" option I was able to do the installation on the remaining 40 GB partition of my SSD. The track pad was sluggish and the pointer jumped all over the place (but works fine after the installation) so it was a bit challenging to get all the options. After reboot from install, there was no wifi and I had to find how to manually install the drivers (they were on the USB drive but not automatically installed). For those who may encounter this problem in the future, here's what I did:

    Plug in the installer thumb drive. Two files needed located on the USB thumb drive:

    pool/main/d/dkms/dkms_2.2.0.3-1.1ubuntu5_all.deb
    pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb

    I copied these files to the root of the thumb drive and opened them in a window. I then opened terminal and typed this command:

    sudo dpkg -i (dragged the bcmwl* file here) <ENTER>
    sudo dpkg -i (dragged the dkms* file here) <ENTER>

    And that was it; wifi worked great after that. There was an update to Ubuntu and after it installed I tried to reboot but the computer wouldn't shut down, so I had to do a hard shut off. After rebooting, the computer shuts down/restarts just fine. So, all seems good now.
     
  4. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #4
    What's the plugin in question/error message?
     
  5. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #5
    Running Sierra on mine. It is the very base 11" model, so even more underpowered than yours and yet it runs coolly without fans unless I run something requiring Flash or similar. The RAM seems to be more of a sticking point than the CPU.
     
  6. Cave Man thread starter macrumors 604

    Cave Man

    #6
    First popup is:

    An unknown error occurred (-50).

    Second popup is:

    “iTea” could not load in 64-bit mode.
    Try contacting the plug-in vendor(s) to see if a 64-bit version is available.


    I don't know if they're the same error, or two separate errors.
     
  7. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #7
    Never heard of the plugin, but try doing this

    1) Open Terminal
    2) If you aren't in your home directory, navigate there
    3) run "ls -aR | grep -y "iTea""
    4) The output of the above command are all the directories and files on your computer that have the name "iTea" in them. If any of them seem to relate to the Plugin, remove them
     
  8. Cave Man thread starter macrumors 604

    Cave Man

    #8
    Well, thanks much. That is progress. Nothing in my home folder, but changing to my hard drive's root and using sudo to launch, I get this:

    WhiteArrowCursor.tif
    markWorldWriteable
    iTea
    iTea_SDK_5.rtf
    AccessibilityDarkGraphiteAppearance.car
    AccessibilityGraphiteAppearance.car
    GraphiteAppearance.car
    WriteAdapter
    ./System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/share/ri/2.0.0/system/Net/InternetMessageIO/WriteAdapter:cdesc-WriteAdapter.ri
    ls: 3: Not a directory
    ls: 4: directory causes a cycle


    So, where is iTea??? Can I use terminal to list complete paths?
    --- Post Merged, Feb 26, 2017 ---
    Ha! I found the iTea issue. It was hidden in a bundle in the /Library/iTunes/Plug-ins folder. So, that problem is gone. However, I still have the error -50 problem. I suspect that's an iTunes issue trying to connect to the iTunes store (I don't use this computer for connecting to iTunes).
     
  9. casperes1996 macrumors 65816

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #9
    Can't help you with that I'm afraid :(

    But for future, if you use the "find" command instead of ls, it'll always be recursive (i.e. go through all the directories below the one you're in), and is you give it a full path as a starting point, it'll output full paths. You can combine it with grep like before to narrow the search.
     
  10. Cave Man thread starter macrumors 604

    Cave Man

    #10
    Will keep that in mind. Thanks very much for your help. I'm pretty sure the -50 error is an authentication error with the iTunes Store. I can live with it for now.
     

Share This Page