MOTU 8Pre - Leopard Ready?

Discussion in 'Digital Audio' started by nylock10, Mar 6, 2008.

  1. nylock10 macrumors regular

    Joined:
    Jun 26, 2006
    #1
    Will a MOTU 8-Pre require drivers (and if so are the drivers compatible with Leopard)?

    I'm eager to start recording stuff, just need to make sure it'll be OK with Leopard.
     
  2. Bobbi Flekman macrumors regular

    Joined:
    Jan 14, 2008
    #2
    Otherwise Register at motu.com and download the new installer. They work as I just installed a 828 on my system.
     
  3. eviltobz macrumors member

    Joined:
    Nov 12, 2007
    #3
    it worked ok with my old g5 running a dev release of leopard and works fine with my shiny new mac pro running 10.5.2. well, not that i've pushed it much yet, but everything seems fine so far :)
     

Share This Page