mount_afp, crontab, and php problem

Discussion in 'Mac OS X Server, Xserve, and Networking' started by paulstanely45, Apr 9, 2010.

  1. paulstanely45 macrumors newbie

    Apr 9, 2010

    I have been having one hell of a time figuring out this one bug. I have been trying to write a script that backups my mysql databases. It worked for the longest time, but now I can an error like this, and I can't seem to figure out why I am getting it.

    2010-04-09 17:28:33.812 mount_afp[7458:613] CFPreferences: user home directory at /Library/WebServerBackup/99 is unavailable. User domains will be volatile.
    mount_afp: AFPMountURL returned error 1, errno is 1

    I am using the crontab to run the script, and that is when it fails. If I run it manually, it works just fine.

    The app essentially mounts the drive, copies mysql data to the drive, and then unmounts it.

    Can anyone shed some light on what is happening. I am using a php call to mount_afp:

    exec("sudo mount_afp -f afp:// $mount_path", $mount_output);

    I have a full script posted at the following link if anyone feels it would help

Share This Page