Mountain lion 10.8.2 wi-fi problem

Discussion in 'OS X Mountain Lion (10.8)' started by Itayiy, Dec 2, 2012.

  1. Itayiy macrumors newbie

    Dec 2, 2012
    Hey all,
    I am using an 21.5" intel based imac.
    Last week i updated the software to mountain lion (10.8.2)
    After about two days a weird problem appeared:
    Wi-fi seems to be connected, and the signal is strong but the computer won't open any internet pages, and downloads are stopping.
    At first, i thoght this is the router's problem but very fast i looked at my ipad, phone and laptop and i saw that they have no problem with the wifi at all.
    So i started to search the internet for possible solutions and i saw the "renew dhcp" trick and first time i tried it fixed the problem. For only 5 hours. Then i saw something with hardware and 1453 but it failed too.
    I was really frustrated so i tried reinstalling mountain lion (what took me 5 hours from my weekend :/ )
    Today i turned the imac on and the problem appeared again...
    I don't know what to do. The wifi crashes every 4-5 minutes and i cant use the computer, not for games and not for internet...
    Really frusturatung problem!! Please help :(
  2. benthewraith macrumors 68040


    May 27, 2006
    Miami, FL
    Some things you could do:
    1) If WiFi is set on WEP, change it to WPA2.
    2) If set on WPA2, adjust the MTu size to 1453.
    3) if it is a wireless n router, force the router to use G only on a strong channel, one that no other wireless device is using.
  3. twintin macrumors 6502

    Aug 10, 2012
    I had a similar issue where my MBA after approximately 2 months all of a sudden either refused to connect to my router or would connect, but without internet connection. But only in my living room and only some days (other days it worked just fine). Also, only my MBA was affected while my Mini, IPod and other devices worked just fine.

    In my case I discovered that when my WiFi connection did not work properly my MBA had picked up the beacon from one of my neighbors router which contained wrong country code (GB instead of SE). I then got the suggestion from Apple support to manually select WiFi channel 6 (in Auto, channel 11 was selected instead, it wasn't crowded, but still affected). After that change my issue went away.

    So, try to change WiFi channel until you find one that works for you. At least it's worth a try.

Share This Page