Mountain Lion (10.8.4) Won't Mount My External HDD D: HELP!

Discussion in 'OS X Mountain Lion (10.8)' started by abyssmal, Aug 13, 2013.

  1. abyssmal macrumors newbie

    Jun 19, 2013
    Okay so kind of a weird issue here. I have two external HD's, one 3TB desktop and one 1TB portable. Both are made by WD, both are great and have had no issues in the past, both bought within the last year. After upgrading to 10.8.4 the desktop drive will mount and works as it should, the portable drive will not mount what so ever, it does not appear in Finder but it does in Disk Utility. Both drives are formatted as exFAT and work fine on my PC and had worked flawlessly before I upgraded my OS. I've also tried to reformat the portable one with no success using Disk Utility as I originally thought something might be corrupt.

    I've connected it using USB and FireWire, tried reformatting and repairing and both hang indefinitely.

    I suppose I can try reformatting it using my PC later tonight but I don't understand why Mountain Lion won't read this HD when it worked perfectly fine for months before when I was running Snow Leopard.

    Anyone got any thoughts/suggestions?

    Much appreciated.

Share This Page