Mountain Lion 10.8 Huawei E173 USB not recognized

Discussion in 'OS X Mountain Lion (10.8)' started by Zaleosmarley, Jul 31, 2012.

  1. Zaleosmarley macrumors newbie

    Jul 31, 2012
    I have a Huawei E173 USB to my MacBook Pro does not recognize the new Mountain Lion 10.8. Nor do they light the light, or is mounted on the desktop.

    The USB is Jazztel, a Spanish company and its service tells me it's the first notice and that currently is not compatible with 10.8.

    I searched the internet but found nothing, could anyone help me?, Thank you very much.
  2. snakes1969 macrumors newbie

    Jan 19, 2013
    This answer is probably too late, but I solved it today, as I had problems with a dongle:
    The dongle didn't read at all, no power as you said. Then I added a USB splitter, as I loaded the drivers from the E-173 to a stick on another computer, and guess what: it works... I can't explain, but it works on 2 MBP (my colleague & mine).
  3. Eithanius macrumors 65816

    Nov 19, 2005
    I know it sounded strange, but since you loaded the E-173 driver, please make sure your FB Click To Post button on Notification Center works...
  4. BazzaS, Jan 28, 2013
    Last edited: Jan 29, 2013

    BazzaS macrumors newbie

    Jan 28, 2013
    MBA13", early 2011 purchase.

    E173 worked fine on Lion, stopped being recognised when updated to MLion (OS X 10.8).

    Fixed, by deleting previous mobile partner software, deleting modem from "Network" settings, before re-installing latest (Aug 12) 10.8 drivers from

    Modem (USB) stick then recognised when next inserted.
  5. cool11 macrumors 65816


    Sep 3, 2006
    I have an old huawei e220 modem for use with my mac.
    I function properly at the time being, but I don't think will be mac-compatible in the near future.

    I am thinking of purchasing a new one huawei usb 3g modem, like e173.
    I think it is fairly new.
    Can I hope that it will a good choice if I buy it?
  6. alejandromay macrumors newbie

    Aug 7, 2013
    Could you tell me please how to delete modem from "Network" settings?
    I'm newby to mac and I can't figure out how to do this.
  7. oscarguindzberg macrumors newbie

    Nov 26, 2013
    I have a macbook pro early 2013 with Mac OS X 10.8 (mountain lion)
    I had the same problem with E173.
    Fixed it using a USB hub

Share This Page