mountain lion and aftermarket SSD

Discussion in 'OS X Mountain Lion (10.8)' started by toastie, Jul 25, 2012.

  1. toastie macrumors newbie

    Jul 19, 2012
    so who has put ML on a mac with an aftermarket SSD installed?
    and problems?
    i am looking to download it but have a mid 2010 mac book pro with a samsung 830 SSD installed am i looking for trouble?
  2. GimmeSlack12 macrumors 603


    Apr 29, 2005
    San Francisco
    I installed an Samsung 830 in my 2008 iMac and no problems. You'll be fine.
  3. ToastMonster macrumors newbie

    Jul 25, 2012
    I installed one in my mid-2010 MBP a month ago running lion. no problems at all.

    Upgraded to Mountain Lion today, It was an epic failure.
    Had to reinstall mountain lion to my hard disc that's still in the mbp.
    don't know what to do to get to all my files on my ssd and get it to work.
  4. mmomega macrumors demi-god


    Dec 30, 2009
    DFW, TX
    Have it installed on
    an Intel 80GB SSD in my wife's '09 iMac
    a ForceGT in my '11 iMac
    and a ForceGT in my wife's '09 MBP

    all of the above are working just fine.
    Clean installs all around.
  5. toastie thread starter macrumors newbie

    Jul 19, 2012
    What make of drive did you install?
  6. alexreich macrumors 6502a


    Jan 26, 2011
    I have a 60GB OWC SSD and the install went fine. Rather speedy too. ML is actually 8-10% faster on my mini according to the benchmarks I ran after the installation completed.
  7. JPCovington macrumors newbie

    Jul 25, 2012
    2011 mbp

    So for my 2011 MBP I'm planning on buying this SSD:

    What is the easiest way to do a clean install of Mountain Lion to the new SSD when I put it in? Can I download ML to a jump drive?
  8. mmomega macrumors demi-god


    Dec 30, 2009
    DFW, TX
  9. jdmmike macrumors newbie

    Apr 29, 2011
    I've installed ML on my mid 2010 mpb with a 128 gb Samsung 830 ssd. Everything runs fine, no hiccups boot time is 17 secs for me..
  10. toastie thread starter macrumors newbie

    Jul 19, 2012
    Did you do a fresh install or was it already installed and running lion and you just did an upgrade? Have you used a third party trim enabler?
  11. jdmmike macrumors newbie

    Apr 29, 2011
    I did a fresh install of Lion when I originally installed the ssd drive..that was about 1 1/2 months ago...ive installed mountain lion this morning, didnt do a fresh install since i already did with Lion and I also keep my working files/documents/photos/music on a separate hard drive via western digital my passport..I only have emails and programs on my mpb only, I completely work off of my portable hd...and I also do not have trim enabled..
  12. TechThule macrumors newbie


    Mar 26, 2011
    I had a problem

    ML installer aborted when I tried to install on a Crucial 250 GB drive on a spring 2011 i7 MBPro. Error: Could not create recovery system.
  13. thatoneguy82 macrumors 68000


    Jul 23, 2008
    Beach Cities, CA
    I have it installed on a Crucial m4. I upgraded from Lion with no issues during the download or installation process. However, it did turn off the TRIM support that I had placed, but I was glad that the same process works on ML as well.

    And according to System Info, my recovery drive is 650MB. I booted into that after I installed to do a random repair/verify of my disks.
  14. ToastMonster macrumors newbie

    Jul 25, 2012
    not positive what you're asking..
    I installed onto my samsung 830 ssd first, didn't work. that will only boot in recovery mode.

    when i enter recovery mode it gives me the option to reinstall ML, so i chose this option and installed ML onto the MBP's original hard disc, which i was using to store files and stuff i don't always need.

    kind of stuck here. need to find a way to get my ssd working again.
  15. ugp macrumors 65816


    Jan 7, 2008
    Inverness, Florida
    Install with a Crucial M4 and no issues. Did an upgrade install over Lion.
  16. dixido macrumors member


    Aug 29, 2010
    I just made a fresh install of Mountain Lion on my 2010 MBP with Intel x-25 160gb SSD. No issues at all.
  17. ToastMonster macrumors newbie

    Jul 25, 2012
    is there a way to figure out what i did wrong and fix it?

    What i'm doing now to fix this is going to take forever.

    moving all my files on my hard disc to an external, copying over all my system settings and apps from my ssd which is in recovery mode to my HD which is working, then using CCC to copy over from the HD to the SSD.

    This is literally going to take me days.
  18. mrjayviper macrumors regular

    Jul 17, 2012
    Using OCZ agility3 as boot/apps/OS drive and no problems here. I think the controller is a sand force.
  19. swordfish5736 macrumors 68000


    Jun 29, 2007
    my unibody MBP has an OWC SSD in it and had no problems installing ML last night. Went to install on my mini with a samsung 830 SSD and ran into the "could not create recovery partition" error
  20. ToastMonster macrumors newbie

    Jul 25, 2012
    let me know what you do to fix it. Mine has been having massive issues, had to install it on my old HD to get it working. all my files still sitting on my SSD though.
  21. ddixon752 macrumors newbie

    Nov 14, 2006
    Failed install on Crucial M4

    I tried to do un upgrade on my Crucial M4 256 - install failed and trashed the system on the drive so that it would not boot. Installed ML on another drive in my Mac Pro, wiped my ssd, still would not install. In desperation I kept running Disk Repair and after two Disk Repairs the install finally took.

    I had a Time Machine backup, but it would not restore - I didn't know there was a problem using one TM disk for multiple source volumes. TM kept trying to Restore 3 hard drives onto the ssd. Had to manually copy files across, including prefs, etc. to get things back working. Took hours. Worst problem I've ever had with an OS update (user since System 6 in 1990).

    Oh, yeah, the sad is three weeks old. Now that I have it working, the Mac does seem a little faster than in Snow Leopard. And I dislike that you cannot set a default font in Safari without making a .css file, and I also need to figure out how to turn off Screen Saver requiring a password.
  22. swordfish5736 macrumors 68000


    Jun 29, 2007
    one of the fix's that i saw worked for at least a few people was go into disk utility and resize the partition for the OS down by 1gb giving the install space to put a recovery partition on. Didnt work for me though but only takes a few minutes to do and is worth trying.

    One of the other solutions is to wipe the drive clean and do a fresh install, I may end up doing this but i'm going to try a few other things first
  23. ToastMonster macrumors newbie

    Jul 25, 2012
    I tried reseting my PRAM as i saw some people do that but it didn't work. I'm in SAFE MODE now trying to get some files off.

    This is the report it sends to apple:

    Interval Since Last Panic Report: 88 sec
    Panics Since Last Report: 2
    Anonymous UUID: 5AF0DF3C-DF40-42A7-B82D-A0A271DEF078

    Thu Jul 26 13:47:47 2012
    panic(cpu 3 caller 0xffffff8004043d5e): "a freed zone element has been modified in zone: kalloc.128"@/SourceCache/xnu/xnu-2050.7.9/osfmk/kern/zalloc.c:219
    Backtrace (CPU 3), Frame : Return Address
    0xffffff80f4e83720 : 0xffffff800401d5f6
    0xffffff80f4e83790 : 0xffffff8004043d5e
    0xffffff80f4e837d0 : 0xffffff80040435a2
    0xffffff80f4e838b0 : 0xffffff80040245bd
    0xffffff80f4e838e0 : 0xffffff800436979d
    0xffffff80f4e83920 : 0xffffff7f861da24f
    0xffffff80f4e83970 : 0xffffff7f861db17a
    0xffffff80f4e839d0 : 0xffffff7f861db514
    0xffffff80f4e83a00 : 0xffffff8004126e02
    0xffffff80f4e83a30 : 0xffffff8004312b28
    0xffffff80f4e83aa0 : 0xffffff8004111c06
    0xffffff80f4e83ae0 : 0xffffff800410932c
    0xffffff80f4e83b90 : 0xffffff80040fbb09
    0xffffff80f4e83c40 : 0xffffff80040fc2d4
    0xffffff80f4e83f50 : 0xffffff80043e17da
    0xffffff80f4e83fb0 : 0xffffff80040cecf3
    Kernel Extensions in backtrace:[5461F87D-B177-359F-BCBA-AAD93F1AA676]@0xffffff7f861d9000->0xffffff7f861dcfff

    BSD process name corresponding to current thread: NotificationCent

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 12.0.0: Sun Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64
    Kernel UUID: 8D5F8EF3-9D12-384B-8070-EF2A49C45D24
    Kernel slide: 0x0000000003e00000
    Kernel text base: 0xffffff8004000000
    System model name: MacBookPro6,2 (Mac-F22586C8)

    System uptime in nanoseconds: 12895417969
    last loaded kext at 8910932657: 1.60 (addr 0xffffff7f8644f000, size 28672)
    loaded kexts:
    com.trendmicro.kext.KERedirect 1.0.0
    com.serato.usb.kext 2.3.0
    at.obdev.nke.LittleSnitch 2.5.3 1.60 3.0 1.9.5d0 2.3.0f2 122 4.0.9f8 2.3.0f2 2.3.0f2 100.12.69 1.0.2d2 3.5.10 1.0.0 4.0.9f8 4.0.9f8 2.0.2d0 1.6.0 3.2.6 170.2.3 1.0.33 8.0.0 1.0.0d1 7.0.0 3.2.6 1.0.0 8.0.0 8.0.0 3.0.2d6 235.4 235.4 235.4 3.5.1 320.15 3.1.0 3.0.1 1.0.0d1 1.0.0d1 34 404 2.2.0 600.15.20 4.9.5 5.1.6 2.4.0 3.2.5b3 5.1.5 5.1.5 1.6.1 161.0.0 1.6 1.5 1.7 1.9 1.6 1.6 196.0.0 4.0.39 2 196.0.0 1.0 10.0.6 2.3.0f2 1.8.9fc9 1.6 1.0.10d0 4.0.9f8 2.2.5 2.3.0f2 2.3.0f2 1.0.4 1.0.10d0 86.0.2 4.0.9f8 3.2.6 1.0.0 5.2.0d16 8.0.0 8.0.0 2.3.4 2.3.4 3.1.3d11 235.7 5.0.0 3.5.1 3.5.0 3.5.1 5.1.5 5.0.0 500.15 4.5.5 2.2.0 5.0.0 1.0.2b1 3.0 5.1.6 1.6.1 1.8.0 1.1 220 1.0.0d1 7 344 1.8 28.18 1.6 2.7 1.4 1.0
    Model: MacBookPro6,2, BootROM MBP61.0057.B0F, 2 processors, Intel Core i5, 2.53 GHz, 8 GB, SMC 1.58f16
    Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB
    Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x04CD, 0x46412D38353030434C372D34474253510000
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x04CD, 0x46412D38353030434C372D34474253510000
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 4.0.9f8 10405, 2 service, 11 devices, 0 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS545050B9SA02, 500.11 GB
    Serial ATA Device: SAMSUNG SSD 830 Series, 512.11 GB
    USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfa100000 / 2
    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa130000 / 5
    USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 4
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8218, 0xfa113000 / 8
    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0xfa120000 / 3
    USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfd100000 / 2
    USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0xfd110000 / 4
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3
  24. captndave macrumors newbie

    Aug 10, 2011
  25. Sital macrumors 68000


    May 31, 2012
    New England
    If you make the ML USB installer you can do a clean install on your SSD. That's exactly how I did it on my new SSD.

Share This Page