Mountain Lion Bluetooth Not Functioning Properly

Discussion in 'MacBook Pro' started by welsh.nick, Dec 19, 2012.

  1. welsh.nick macrumors newbie

    Dec 18, 2012
    I am trying to use this software to turn the surface that I am projecting the MacBook Pro on into an ActivBoard/Smart Board. It was working just fine in Mountain Lion (after a Google search as it was not compatible to Mountain Lion but I found a work around) but now after installing a system update, it won't connect to my wiimote. I tried adding a new device and the Bluetooth Setup Assistant would not respond for a few seconds and then responded again and it found no Bluetooth devices. It wouldn't find my phone (which was in discoverable mode) or any other computers that had bluetooth turned on and where in discoverable mode. Also, the Bluetooth panel in System Preferences was acting a little buggy. I couldn't remove any devices and it would become unresponsive for a few seconds if I toggled Bluetooth off and then back on. Also If I go to Apple Menu>About This Mac>More Info>System Report>Hardware>Bluetooth I see "There was an error while gathering this information." The Bluetooth menu seems normal but I am thinking that there are some issues with Bluetooth. Any Ideas?
  2. Mojo1 macrumors 65816

    Jul 26, 2011
    If you are using USB 3.0 interference on the 2.4GHz band can disrupt Bluetooth and WiFi. It's caused by the USB 3.0 port and cables with inadequate shielding.
  3. welsh.nick thread starter macrumors newbie

    Dec 18, 2012
    I guess that makes sense but I find it strange that it was working and after a system update it won't work. Other people are having similar issues but they don't get any options under the bluetooth menubar icon but I do. I can access everything for bluetooth on the computer (menu, system preferences, etc.) but I can't connect a bluetooth device.
  4. Mojo1 macrumors 65816

    Jul 26, 2011
    I was just offering one possible reason; the fact that the problem began immediately after the upgrade would lead me to believe that it is the likely cause of your problem.

    But since I found the USB 3.0 interference to be intermittent it is worth checking out. All you need to do is disconnect the USB device and see if Bluetooth access is restored. If your Bluetooth problem goes away then you will know that USB 3.0 is the culprit.
  5. welsh.nick thread starter macrumors newbie

    Dec 18, 2012
    Ok. When I did this, the only thing plugged into the computer was the power supply. I have also restarted the computer several times and still nothing. Can the USB 3.0 interface still be the problem?
  6. Mojo1 macrumors 65816

    Jul 26, 2011
    AFAIK the USB 3.0 port has to be in use. When I ran into the problem connecting via Firewire made the problem go away.

    I reread your original post. It sounds like the system update broke the workaround so now your Bluetooth is not working. (I suspect that Java is the culprit...) These things happen to even the best programs; shareware can be even more prone to developing problems after an OS update. You can try uninstalling the software or use Time Machine or a cloned backup to return your Mac to its original state to get it back to normal.

    I try to always have an up-to-date backup in the wings prior to doing an OS upgrade or any significant change that might disrupt my Macs. Then if something goes awry I can easily revert the Mac to its previous state.

    Have you posted your problem on the Wiimote Whiteboard forum? Perhaps the developer can fix the bug that is causing the problem...
  7. cgaw macrumors newbie

    Dec 11, 2012

    You should bring it to the store or if not then maybe try to fix it on your own.

    27" iMac 10.7 1TB
    11" MacBook Air 10.6 64GB
    iPad 32GB iOS 6.0.1
    iPod Touch 32GB iOS 5.0.1

Share This Page