Mountain Lion Install Attempt Destroyed My Machine- Advice?

Discussion in 'OS X Mountain Lion (10.8)' started by orvn, Jul 26, 2012.

  1. orvn, Jul 26, 2012
    Last edited: Jul 26, 2012

    orvn macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    So I was running OSX 10.7.4 on my mid-2009 13"MBP.

    This morning I decided to upgrade to Mountain Lion.

    I bought it and proceeded to download it via the app store. I backed up my drive using time machine right at that moment, as it occurred to me that it might be a good idea.

    I was not able to complete the download without closing my machine, taking it elsewhere and opening it back up again (resuming the download).

    Once the download was complete, I began the installation process (physically at thew new location now).

    Some time later I'm faced with the error message:
    "OS X Mountain Lion Couldn't Be Installed, Because The Disk Local Is Damaged And Can't Be Repaired"


    I tried everything I could think of. When I attempt to install it finds my time machine drive (USB), the Mac OSX Install ESD and eventually- after about a ten minute wait- it finds my "Local" drive.

    When I try to install 10.8 the installation fails with the error I mentioned earlier.

    When I try to restore from Time Machine via the Mountain Lion install interface it never finds my local HDD.

    Disk utility won't let me select the drive "Local". It's greyed out. (see screenshots)

    I should mention: my current HDD is about 9 months old. It's not an SSD and has always functioned without issue.

    I got it because I really wanted a 7200rpm drive rather than the standard 5400.
    I've never had any reason to suspect bad sectors or any sort of damage.

    I haven't subjected my Macbook Pro to any impact. This all just occurred with the ML install.

    Am I screwed? I'm a programmer/designer/marketer, so I REALLY need my machine.

    Advice? (more photos below, screenshot function wasn't installed in the ML boot interface).

    I'm going to the Genius Bar tomorrow and a new 2.5" SATA drive is always a hundred (or so) bucks away, but I welcome any other ideas with open arms.







  2. benguild macrumors 6502a

    Jul 29, 2003
    I mean, it sounds like the drive failed. I've killed drives before, especially SSDs in notebooks.

    Luckily, it sounds like you have a Time Machine backup?
  3. orvn thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    It isn't an SSD though. And given the fact that the disk was largely fine at first and I didn't subject the chasis to any strain or impact, the cause would appear to be the Mountain Lion installation.

    Fortunately, yes. I have a Time Machine backup from minutes before I tried the Mountain Lion install.

    Thanks! Useful thread. Participating in it now.
  4. asvictory macrumors newbie

    Jul 27, 2012
    I had the same issue, and was on the phone with Apple Senior support for about 45 minutes. We couldn't figure it out, so he suggested that I take it to genius bar and they ended up replacing my HDD after a clean wipe and reinstall attempt failed on my other hard drive. I basically had the same situation with you, this came out of the blue for me as well, and I had the same unmounted, greyed out options as well.

    Late 2011 13" MBP, 500 GB 5400 rpm.
  5. madat42 macrumors regular

    Mar 25, 2011
    How about using the disk utility to erase your hard drive completely first and then restoring from your time machine backup? Then try downloading Mountain Lion again. Good luck!
  6. NeoMayhem macrumors 6502a

    Aug 22, 2003
    This right here. Many issues like this can be fixed if you wipe the drive. Otherwise, it is probably a hardware failure.
  7. haravikk macrumors 65816

    May 1, 2005
    The fact that the Local volume is greyed out in Disk Utility just means it isn't mounted or unlocked. You should be able to select the actual physical disk and use Disk Utility to erase it back to a clean HFS journaled volume with a name of your choice.
    You'll need to do this from a bootable disk, or you could use the remote restoration process, as erasing the whole disk would mean erasing the recovery partition from which the installer operates, which isn't possible.

    My main thought is that something weird may have gone wrong when Mountain Lion updated the recovery partition, and it's screwed up the Local partition in the process.
  8. CoreForce macrumors regular

    Aug 28, 2003
    Zurich, Switzerland
    I'm facing the exact same issue right now.
    iMac 27" from 2009 I think, Core Duo 2.

    Installed iLife and iWork update before that.

    After ML download, installation, it complaints about the Harddrive to be irreparabel corrupt.
    I do see the exact same screens.
    Can not recover the machine from backup either.
  9. Daptin macrumors newbie


    Jan 16, 2011
    Mountain Lion destroyed my MacBook Air

    Same exact issues... my disk is beyond repair! Don´t know what to do... To make matters worse, I am currently traveling in the Republic of Panama!
  10. Plutarch macrumors newbie

    Jul 27, 2012
    Mountain Lion Installer disk damage fix

    I had this problem and just got my MacBook Pro running again. In short, the ML installer did major damage to the directory of the drive the OS is installed on, making it unusable. Apple's Disk Utility could not repair the drive's directory. Applecare told me that I had to format the drive and install the old OS. This would work, but was not necessary in my case.

    DiskWarrior by Alsoft was able to repair my severely damaged hard drive directory.

    Once DiskWarrior repaired and replaced the drive's directory, I rebooted, and the ML installer started again. After running for a few minutes, it threw an error telling me that it couldn't install because it couldn't make a recovery partition on my drive (I will not address this error in this thread, it's a different problem.). The installer allowed me to restart and revert to my previous operating system, which I am using right now to type and post this the comment.

    My system seems to be running as it was before I attempted the ML install. It appears that I lost no data, applications, or application settings. I'm not going to bother with ML at this time, since my system is working correctly again, and I don't really need any of the newest features right now. (I know better than to be an early adopter, grrr.)

    In my case, the ML installer DID NOT damage the existing operating system, damage any of my data, nor did it do irreparable damage to the drive. I DID NOT NEED TO FORMAT the drive, I just needed to repair the drive's directory with a utility that could actually fix it.

    To use DiskWarrior to repair your drive's directory, you must either

    • boot your broken Mac to a new enough DiskWarrior dvd (my version 4.1 would not boot my 17" i7),

    • boot your broken Mac to a different drive (or partition) with MacOS and DiskWarrior installed on it, or

    • connect your broken Mac to another Mac with DiskWarrior on it (using a Firewire cable), and boot the broken Mac in "Target Mode" (hold down the "t" key when you start it). Target mode allows the second Mac to access the drive of your broken Mac. I used this method, connecting my MacBook Pro to my old PowerPC Powerbook, by the suggestion of Alsoft tech support, using the instructions on their web site. (Research Target mode for more details/options.)
    I am in no way affiliated with Alsoft.

    I'm furious with Apple, though. This is the kind of crap we associate with Microsoft. And to get pure BS from the AppleCare folks is inexcusable (I left their BS out of this post, for brevity's sake, but it was ludicrously stupid, I assure you.).

    I hope this post helps point some of you in the right direction.
  11. orvn thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    Went to the Apple Store today. I confused the 'genius' by showing him some unix moves. That was pretty much my only success.

    Essentially his only advice was to buy a new HDD. He brought up an extra drive from the back and installed it into my machine. This drive appeared to work.

    Upon retroanalysis I realize I wasted my time. He troubleshooted it less comprehensively than I did and came to a hasty conclusion despite my insistence that the issue is not permanent physical damage to my disk.

    * * *

    Disk utility won't let me unmount the partition. When I try to erase or repartition the disk the first task disk utility must complete is unmounting the current partition, which does work.

    Even tried sudo force unmounting it via unix with no luck which really took me aback.

    I think you're right, I can access the disk, but not the partition. The ML install somehow damaged it.


    Thank you for the detailed post! I'll try this soon and see what happens.
  12. CoreForce macrumors regular

    Aug 28, 2003
    Zurich, Switzerland
    Here is how I got away with it:
    Use the DiscUtility Repair on the Volume "Macintosh HD", though it is grayed out and installer claimed it to be impossible.

    Situation was that: on install, right after 30 seconds or so, installer complaint about the disc being damaged and could not be repaired.
    Like the first screen photo of this thread "Install Failed".

    Using the OSX stock Disc Utility, the drive ("1 TB .... Media") was available but the volume "Macintosh HD" was grayed out.
    Using repair on the drive itself did not do anything, it was reporting everything is fine on the partition.

    Finally, on a last check before putting the thing into it's box for transport, I gave it a click to the gray "Macintosh HD" and to my surprise found the "Volume Check" button still available. Doing that, the repair check sequence kicked in and reported:
    - 2 additional leafs found that were not in the catalog
    - 1 additional folder found that was not on file
    Guess where they were coming from...

    Final message: Volume has to be repaired. Repair button showed enabled.
    I gave little hope to it as the installer already stated contradictory.
    But at the end I've got a green light.

    Then, when trying the install on the "Macintosh HD", it was complaining the drive is locked. Bummer.
    But this was from the repair process I assumed and rebooted, after which the installation procedure kicked in automatically and completed without any issue.

    I wish everybody facing the same issue good luck with this procedure.
  13. hallux macrumors 68030


    Apr 25, 2012
    Reading this makes me think my decision to wait on the install until I get an 8 GB flash drive to build an install drive is a wise decision. I have a 12 GB mini HDD USB device and tried to build to that but it failed. I think having that allow you to boot to that and avoid the issue of the disk being locked when trying to repair.
  14. njean777 macrumors 6502

    Oct 17, 2009
    no offense but why would you sleep in the middle of an install of your OS, it seems you were just asking for problems...
  15. orvn thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    I put it to sleep in the middle of the 10.8 download, not the install.

    Unfortunately it couldn't be helped, I had something unexpected turn up requiring me to go work somewhere else that morning.

    You can pause the download of items from the app store.
  16. orvn thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    Well, the DiskWarrior (4.3) DVD didn't boot on my MBP either.
    Time to buy a firewire cable.
  17. Mal macrumors 603


    Jan 6, 2002
    Wait, so another drive worked, and yours didn't, yet you're still insisting you know better and that your drive is fine? Drives die. It's a fact of life. The fact that it's 9 months old is completely irrelevant. There's a very good chance that your drive died, as all of the symptoms very clearly point towards. Fortunately, it should be under the manufacturer's warranty if it's that young. Just replace it and move on like any normal person would.

    I say this as an Apple Certified Macintosh Technician, btw.

  18. haravikk macrumors 65816

    May 1, 2005
    I think the point was that the drive may well have been fine, but the genius didn't really do enough to determine if that was in fact the case. Just because a new drive worked doesn't mean that the previous one had a hardware problem, as a new drive also eliminates all partition and file-system problems as a cause as well.

    It's fairly common among diagnosis to jump to worst case; in fact I did it myself earlier in the thread by assuming that the drive may need to be reformatted, but as Plutarch and others have pointed out it may be a more minor problem, but one that the OS X installer simply can't address since it's running from the same drive.
  19. aziatiklover macrumors 68030


    Jul 12, 2011
    Location: and
    I feel you OP, but why go all hassle just for a cheap HDD can buy nowadays? Just go to frys get yourself a 1TB 7200RPM then done! Or you can get yourself a nice ssd for really cheap now.
  20. Daptin macrumors newbie


    Jan 16, 2011
    Mountain Lion attempt destroyed my machine: PROBLEM SOLVED!

    My problem was WORSE than yours... because I bought my MacBook Air in the US, my Apple ID, my address, my credit card, etc... is in the US, but I am currently visiting PANAMA (an Apple rep wanted to know what this was, and I had to explain it was a country... I asked if he had heard of the Panama Canal and he had not... he probably thinks Michael Jordan occupies a seat in the U.N.). That means, among other things, that there are no genius bars in Panama - which is probably not such a bad thing if you consider that the first thing some of these "geniuses" recommend is replacing the hardware, when this is obviously a software issue.

    My MBA was working fine until I bought the ML upgrade. Upon installation, I had to go through all those depressing screen shots and quickly found out my HD could not be repaired. Luckily, I had purchased Apple care... The first agent (I spoke to about 8 of them in the course of 2 days) gave me the instructions to perform an Internet Recovery: hold option/command/R while turning the machine on. To do that, you obviously need an Internet connection, but for some reason my Wi-Fi didn't show up on the list and the only solution I found was to connect through my iPhone Personal Hotspot. It took 12 hours... (in retrospect, since I was about to wipe off the HD, I should have done that from the start and it would have taken less time to do the procedure with 1 GB instead of 200 GB). Eventually I was taken to a screen with disk utilities options. I called Apple again, not wanting to do something stupid... on my own. I was instructed to create a single partition, with extended journaled (don't ask me!) etc... Everything went along fine, until at the end, when I needed to insert my Apple ID. Permission was denied... Pretty frustrating, to say the least... The issue was now that the IP address showed I was NOT in the US, but I had a US Apple ID... I requested to escalate the case and apparently no one had a solution to this. I observed that Apple had no problem selling me the ML upgrade (or any other app) while traveling outside the US...

    The solution? To perform another Internet Recovery... This time, as we had wiped off the system, it took only about 5 hours. After which I called Apple again... You know the definition of crazy: to repeat the same thing and expect different results. I ended up talking to another senior adviser. Actually, she did all the talking... whenever I spoke she would drown my words with non-stop chatter. She offered to provide me with her contact information and I said: "please don't" before hanging up. She had me change my real US address with a fake Panamanian address. I did, but very reluctantly. I didn't think this would fool the system. I called back once again, and this time I had a great rep on the line. He had a better idea... I had completely forgotten about that little USB key that had come in the package of my MBA... I rebooted using that recovery key. He told me that was a temporary fix and that I would need to travel back to the US to have my stuff back... Not very encouraging... OK, now my system was back to Snow Leopard, like it was when I purchased the MBA. I had make a Time Machine back up, two months earlier (not to self, do a back up before upgrading!) and of course it was on Lion, so I went to the app store and tried to download again Lion, but the only option was ML so I decided to select the new OS anyway. It worked. After that, I selected migration assistant and transferred from the Time Machine back up. I got a weird message saying that the system was preventing log out and I had to call Apple again. It took a few simple steps (the back up had created a new user and I had to select the one I wanted and delete the useless one) and now I'm back on track. Like nothing happened, except my two months of data that I hadn't backed up... Of course, you can do the same thing with a replacement HD, but that doesn't sound necessary!
  21. orvn thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    Exactly. I'm wasn't insisting that something was wrong which wasn't.
    My hypothesis was that the boot sector of my main partition was injured when the 'Mountain Lion Install ESD' was copied.

    Because certain failsafes are in place, hard drives are very rarely physically damaged when obeying software-driven commands.

    I've heard of people running certain assembler code that damages internal components, that's about it.

    Ostensibly replacing a hard disk would fix the issue- as would replacing the whole machine. That doesn't mean that the faulty issue is the entire machine. The Genius failed to segment possible issues into a hierarchy and instead jumped to the easiest- for him- solution.

    I work all the time, so part of the problem is the lack of free time to truly address this issue.


    I'm considering it. I'm also waiting for the 13" Retina Pro's to come out before I get a new one, so I'm somewhat against putting more money into my current machine.
  22. throAU macrumors 603


    Feb 13, 2012
    Perth, Western Australia
    Sounds like your disk died, and the ML install uncovered the fault because it was writing to parts of the disk that hadn't been touched recently.

    ML didn't kill your machine, it had a fault, the install merely uncovered it.

    Buy new disk, reinstall, restore from TM backup.

    You may be able to repair/re-format the old disk to get it back but you need to ask why it screwed up in the first place.
  23. concernedone macrumors 6502


    May 26, 2011
    wow...I cannot believe that you went through this whole ordeal and still kept a positive attitude and still stuck with :apple:? :confused::eek: because there is 1 other painless option (windows 7)
    and that person who helped you never heard of Panama? wow... >.<
    What's your secret? how do you keep this positive attitude? I would've been so mad. I'm still a bit peeved about Lion and ML OS (with all the bugs and the new implementations). snow leopard was my fav mac os--it was relatively stable and doesn't have so much animation.
  24. orvn, Jul 30, 2012
    Last edited: Jul 30, 2012

    orvn thread starter macrumors 6502

    Jan 11, 2011
    Toronto, Canada
    Well this is odd.. my damaged Macbook Pro boots into target disk mode, but my other Macbook Pro (my wife's) doesn't detect it.

    Connected the two via a male-male 9/9 pin 800 megabit firewire cable.

    No other firewire devices attached, cable is new.

    * * *

    ISSUE RESOLVED! (thanks to Plutarch's solution, above).

    I'm now typing this from my fresh Mountain Lion Install.

    After buying a suitable firewire cable (9pin male/male 800mbit), I connected my machine (the target) to another, newer, MBP (the host).

    I started the target machine up in target disk mode (holding 't'). Oddly, I had to wait almost ten minutes before the host detected this drive.

    I installed Disk Warrior 4.4 on the host (~/Applications/Utilities) and ran it on the target drive.

    1. I graphed the drive (which happened to be a mess, see image)
    2. I rebuilt the drive ('directory' tab)
    3. I replaced the drive with the rebuilt version (took a while)
    4. I ran a check on all files and repaired permissions via Disk Warrior (files tab)
    5. I ejected the target disk.


    Running the Mountain Lion installer didn't work right away though. I noticed that it only worked if I didn't let the MBP display go to sleep during installation (i.e.- I periodically moved the cursor).

    After an hour of installing it was ready! Thanks to Plutarch and everyone who advised.

Share This Page