Mountain Lion Install Process Crashed my rMBP - Now it won't boot...

Discussion in 'OS X Mountain Lion (10.8)' started by jlevi, Jul 26, 2012.

  1. jlevi macrumors member

    Oct 9, 2008
    -Downloaded Mountain Lion (paid for it, because Apple screwed up big time on the Up-to-Date process)...
    -Chose the install disk
    -Installer said "Restart to begin the install"
    -Prompted me to close all applications

    From there, it started a loop:
    -Apple Logo
    -Black text in the top left corner, looks like a kernel panic or something
    -Your computer restarted because of a problem. Press any key or wait a few seconds to restart...

    Uh... what do I do here?

    -I'm traveling - my backup is safely at my next destination
    -This machine does not have a CD drive

    Do I do a disk utility? Reinstall Lion? Etc?

  2. halvo1 macrumors newbie

    Jul 26, 2012
    Yep - exactly the same problem has happened to me!!

    Keeps crashing at startup with the black kernel screen. =(

    I'm writing from the 10.8 recovery thing after holding down option during boot.

    Already tried re-downloading and reinstalling but it still crashes.

    I'm using 2009 mac pro with no modifications.

    Any ideas or help would be great!!
  3. C.G.B. Spender macrumors member

    Jul 10, 2012
  4. jlevi thread starter macrumors member

    Oct 9, 2008
    Solved (now typing to you from Mountain Lion). I hope this helps you!

    1. During boot, hold Command R to get to recovery mode
    2. While there, go to disk utility
    3. Repair Permissions (Just incase, it can't hurt)
    4. Repair disk (this also can't hurt)
    5. Restart
    6. During restart, hold Ctrl + Command + P + R to reset the PRAM
    7. After this, the computer will flash and restart again. Hold Shift to boot to safe mode
    8. This will hopefully work. Restart your computer normally as soon as it boots up, to let it get a healthy restart
    9. With any luck, it will boot up into the OSX Installer (mine did) and you'll be well on your way to Lion


    Agreed. This, combined with the Up-to-date nightmare is NOT what I have come to expect from Apple AT ALL.
  5. halvo1 macrumors newbie

    Jul 26, 2012
    Thanks for the tips - i've managed to load ML in safety mode but when I try to complete your other steps, i keep getting the same error as before.

    I've attached an image of the error before it crashes... It looks like there might be a problem with a realtek driver?? This is my usb internet key.

    Can anyone who understands this stuff please explain if this looks like the issue and if so, should I reboot in safe mode and remove the drivers?

    Any help would be much appreciated!


    Attached Files:

  6. RyanW300 macrumors newbie

    Jul 26, 2012
    Northern Ireland
    Hi I have a mid-2007 iMac. I can't complete step 6, it won't let me restart the PRAM. Holding Cntrl +Cmd + P + R isn't doing anything for me :(. It's getting frustrating nowM. :mad:
  7. halvo1 macrumors newbie

    Jul 26, 2012
    Got mine working now!!

    I rebooted in safety mode (hold shift) and found the relevant driver causing the error and deleted it.. To my surprise, it worked.

    Hopefully realtek will update theirs drivers soon.

    I couldn't do point 6 either..
  8. RyanW300 macrumors newbie

    Jul 26, 2012
    Northern Ireland
    What is the relevant driver causing the error.
  9. heimbachae macrumors regular


    Aug 1, 2011
  10. mike5411 macrumors regular

    Jan 15, 2008
    What sticks out to me is "System Model Name: MacPro4,1 (Mac-F221BEC8).

    That's not a rMBP, thats the Mid 2010 MacPro... :confused:
  11. ToastMonster macrumors newbie

    Jul 25, 2012
    I'm not getting the black text in the corner but i am getting...
    "Your computer restarted because of a problem. Press any key or wait a few seconds to restart."

    Any suggestions? Tried to reset the PRAM but i don't think it's working.

    Booted in Safe Mode and everything works fine but once i restart or shut down and power up, i get stuck in the same loop of "Your computer restarted because of a problem. Press any key or wait a few seconds to restart."

    Any suggestions on how to fix it?


    In SAFE MODE now...
    This is the report it sends to apple:

    Interval Since Last Panic Report: 88 sec
    Panics Since Last Report: 2
    Anonymous UUID: 5AF0DF3C-DF40-42A7-B82D-A0A271DEF078

    Thu Jul 26 13:47:47 2012
    panic(cpu 3 caller 0xffffff8004043d5e): "a freed zone element has been modified in zone: kalloc.128"@/SourceCache/xnu/xnu-2050.7.9/osfmk/kern/zalloc.c:219
    Backtrace (CPU 3), Frame : Return Address
    0xffffff80f4e83720 : 0xffffff800401d5f6
    0xffffff80f4e83790 : 0xffffff8004043d5e
    0xffffff80f4e837d0 : 0xffffff80040435a2
    0xffffff80f4e838b0 : 0xffffff80040245bd
    0xffffff80f4e838e0 : 0xffffff800436979d
    0xffffff80f4e83920 : 0xffffff7f861da24f
    0xffffff80f4e83970 : 0xffffff7f861db17a
    0xffffff80f4e839d0 : 0xffffff7f861db514
    0xffffff80f4e83a00 : 0xffffff8004126e02
    0xffffff80f4e83a30 : 0xffffff8004312b28
    0xffffff80f4e83aa0 : 0xffffff8004111c06
    0xffffff80f4e83ae0 : 0xffffff800410932c
    0xffffff80f4e83b90 : 0xffffff80040fbb09
    0xffffff80f4e83c40 : 0xffffff80040fc2d4
    0xffffff80f4e83f50 : 0xffffff80043e17da
    0xffffff80f4e83fb0 : 0xffffff80040cecf3
    Kernel Extensions in backtrace:[5461F87D-B177-359F-BCBA-AAD93F1AA676]@0xffffff7f861d9000->0xffffff7f861dcfff

    BSD process name corresponding to current thread: NotificationCent

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 12.0.0: Sun Jun 24 23:00:16 PDT 2012; root:xnu-2050.7.9~1/RELEASE_X86_64
    Kernel UUID: 8D5F8EF3-9D12-384B-8070-EF2A49C45D24
    Kernel slide: 0x0000000003e00000
    Kernel text base: 0xffffff8004000000
    System model name: MacBookPro6,2 (Mac-F22586C8)

    System uptime in nanoseconds: 12895417969
    last loaded kext at 8910932657: 1.60 (addr 0xffffff7f8644f000, size 28672)
    loaded kexts:
    com.trendmicro.kext.KERedirect 1.0.0
    com.serato.usb.kext 2.3.0
    at.obdev.nke.LittleSnitch 2.5.3 1.60 3.0 1.9.5d0 2.3.0f2 122 4.0.9f8 2.3.0f2 2.3.0f2 100.12.69 1.0.2d2 3.5.10 1.0.0 4.0.9f8 4.0.9f8 2.0.2d0 1.6.0 3.2.6 170.2.3 1.0.33 8.0.0 1.0.0d1 7.0.0 3.2.6 1.0.0 8.0.0 8.0.0 3.0.2d6 235.4 235.4 235.4 3.5.1 320.15 3.1.0 3.0.1 1.0.0d1 1.0.0d1 34 404 2.2.0 600.15.20 4.9.5 5.1.6 2.4.0 3.2.5b3 5.1.5 5.1.5 1.6.1 161.0.0 1.6 1.5 1.7 1.9 1.6 1.6 196.0.0 4.0.39 2 196.0.0 1.0 10.0.6 2.3.0f2 1.8.9fc9 1.6 1.0.10d0 4.0.9f8 2.2.5 2.3.0f2 2.3.0f2 1.0.4 1.0.10d0 86.0.2 4.0.9f8 3.2.6 1.0.0 5.2.0d16 8.0.0 8.0.0 2.3.4 2.3.4 3.1.3d11 235.7 5.0.0 3.5.1 3.5.0 3.5.1 5.1.5 5.0.0 500.15 4.5.5 2.2.0 5.0.0 1.0.2b1 3.0 5.1.6 1.6.1 1.8.0 1.1 220 1.0.0d1 7 344 1.8 28.18 1.6 2.7 1.4 1.0
    Model: MacBookPro6,2, BootROM MBP61.0057.B0F, 2 processors, Intel Core i5, 2.53 GHz, 8 GB, SMC 1.58f16
    Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB
    Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x04CD, 0x46412D38353030434C372D34474253510000
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x04CD, 0x46412D38353030434C372D34474253510000
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 4.0.9f8 10405, 2 service, 11 devices, 0 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS545050B9SA02, 500.11 GB
    Serial ATA Device: SAMSUNG SSD 830 Series, 512.11 GB
    USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfa100000 / 2
    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa130000 / 5
    USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 4
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8218, 0xfa113000 / 8
    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0xfa120000 / 3
    USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfd100000 / 2
    USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0xfd110000 / 4
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3
  12. beyondvision macrumors newbie

    Jul 26, 2012
    How to Reset PRAM

    During restart, hold Ctrl + Command + P + R to reset the PRAM is incorrect.
    You Must hold down Option + Command + P +R to reset the PRAM. Oh, and I just installed Mountain Lion and the problem I'm having is that my system starts up I can use it for about 10 seconds, then gives me a message that to run Java I must update it and then within 30-60 seconds totally freezes up and forces a restart. It will just keep in this cycle unless I start into Safe Mode, which it is now working, but I have no idea what could be causing this problem.
  13. ToastMonster macrumors newbie

    Jul 25, 2012
    reset the PRAM the correct way.... still not working


    So my SSD isn't happy unless in safe mode but i still have my HD in my MBP.
    My HD has 10.8 installed as well and that works fine, slower, but fine.

    If i were to use CCC to copy essential files over, but not the main OS as i don't want to be stuck like i am with the SSD, what should i select to copy over?
  14. ToastMonster macrumors newbie

    Jul 25, 2012
    Fixed the issue..

    removed trend micro, little snitch and serato's audio drivers
  15. eoinokane macrumors newbie

    Jul 27, 2012
    I can't seem to reset the PRAM on my MacBook Pro or boot into Safe mode. I get the same kernel panic.

    Is re-installing Lion my only choice?

    I feel like I've been mauled by a Mountain Lion!

  16. ToastMonster macrumors newbie

    Jul 25, 2012
    reset by hitting OPTION COMMAND P R at the same time then turn on the machine. it should blink and then start again. this means it worked.

    A lot of people entered recovery mode then got into disk utility to repair disk permissions and repair the disk. do it a few times.

    if you can get into SAFE MODE and apple requests to send an error report. look at it. see what's in it. if anything is not see what comes after the com. and try andfind those files.
    delete them and restart. worked for me.
  17. CARPAKACARP macrumors newbie

    Jul 28, 2012
    i try to delete that same com.trendmicro.kext.KERedirct that you have you in your report in terminal, but everytime i try it says it "can't create it" when i put sudo kextunload. What am i doing wrong?
  18. eoinokane macrumors newbie

    Jul 27, 2012
    Hey ToastMonster,

    I had to re-install Lion as I needed my mac back up and running. I will wait until there is an update from Apple before trying again.

    Thanks anyway.


Share This Page