Mountain Lion Wireless will not stay connected

Discussion in 'OS X Mountain Lion (10.8)' started by MacAndMic, Jul 25, 2012.

  1. MacAndMic macrumors 6502

    Joined:
    Jun 4, 2009
    #1
    2010 iMac -i7 2.93 and never had wireless issues. After installing Mountain Lion it won't stay connected.

    I've deleted the wireless connection and service, then re-added it, same result. It loses connection after a few seconds to 20 seconds or so. I can turn wireless off and then back on and it will stay on for a few seconds but that's about it.

    Anyone else having issues or a possible fix?
     
  2. dcorban macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #2
    I had this exact problem on a 2008 unibody MacBook with a d-link router. I tried everything in the router settings. Works flawlessly with an Apple Airport Express.
     
  3. th3xf4ctor macrumors newbie

    Joined:
    Apr 5, 2010
    #3
    Your lucky that you can even connect to a wireless network...I can't connect and I'm having mail and icloud issues.
     
  4. MacAndMic thread starter macrumors 6502

    Joined:
    Jun 4, 2009
    #4
    Upgrade HW to fix a SW problem....I don't think so!
     
  5. ludeboy12 macrumors newbie

    ludeboy12

    Joined:
    Jul 14, 2010
    Location:
    TN
    #5
    I have the same problem with my 2011 MacBook Pro. Usually happens every couple hours. Wifi appears connected but all data transfer is lost until I reconnect.

    Rather annoying if you ask me.
     
  6. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #6
    I have 3 iMacs running ML and 4 MacBooks.
    The iMacs are a 2009, 2010 and 2011 model and only the '11 is wired.
    The Macbooks are 2009, 2x 2010 models and a 2011 all wireless.

    Zero connectivity issues so far. No device has dropped a signal YET on ML.

    Have not experienced a signal but no data problem YET either.
     
  7. enklined macrumors 6502

    Joined:
    Sep 13, 2007
    Location:
    Sacramento
  8. MacAndMic thread starter macrumors 6502

    Joined:
    Jun 4, 2009
    #8
    Well, at least I am not "unique" and we can only hope for a fix. It works, then it doesn't, no consistentcy. If I go into bootcamp, it's rock solid.
     
  9. RMXO macrumors 6502a

    Joined:
    Sep 1, 2009
    #9
    Try rebooting your rooter & updating to the latest firmware if there is one. Mine stays connected with my Netgear 900
     
  10. MacAndMic thread starter macrumors 6502

    Joined:
    Jun 4, 2009
    #10
    I've done that but thanks for the suggestion.

    Here is one thing that seems to be working so far for me. My connection has been flawless for the last 30 minutes.......YMMV!

    Go into Network Preferences, click Wifi, then advanced. Click TCP/IP and change Configure IPv6 to Link-local only. Like I said, YMMV but the problem acts like a routing issue, not an actual connection issue.

    Hope this helps!
     
  11. enklined, Jul 25, 2012
    Last edited: Jul 25, 2012

    enklined macrumors 6502

    Joined:
    Sep 13, 2007
    Location:
    Sacramento
    #11
    I did a PRAM reset and have had a stable connection for 20 minutes thus far - longest all day.

    For those who need to do this:
    1. Shutdown
    2. Hold Option + Command + P + R and press the power button - CONTINUE HOLDING Option + Command + P + R.
    3. You will here the first startup chime; it will then reboot, and after hearing the second chime, release all keys.

    EDIT: Nevermind, it just **** the bed again. Going to try your solution troutspinner.
     
  12. ozp macrumors newbie

    Joined:
    Feb 23, 2009
    #12
    Having the same issue, started after installing ML today - the wifi icon looks like it still connected but the internet is gone after about a minute. either rebooting the router or turning the wifi off and on fix it, for about a minute or few until it's gone again...
     
  13. Bruno Taut macrumors newbie

    Joined:
    Jul 26, 2012
    #13
    Slow internet speed

    Download and upload speed have been halved (MBP Retina). Very annoying. No problems with my other MBP (Lion).

    ----------

    Measuring the internet speed the first seconds everything seems fine but then it slows down and down and down.
     
  14. Bruno Taut macrumors newbie

    Joined:
    Jul 26, 2012
    #14
    Ethernet

    It just seems to be a wifi issue. Ethernet works fine with Mountain Lion.
     
  15. anschris macrumors newbie

    Joined:
    Oct 1, 2007
    #15
    I'm having a slightly different issue with my late 2011 MBP 13". At times it appears that I lose connection like the rest of you. However, if I try to click on the wireless network icon in the file menu at the top of my screen, I get the pinwheel of death. The rest of the computer seems to work ok, except I have no internet connection. I tried opening System Preferences and tried going to Network and it just hangs. I can't do anything but shut everything down and restart the computer. This has happened several times already.
     
  16. this is funah macrumors 6502

    this is funah

    Joined:
    Oct 13, 2005
    Location:
    Berlin, Germany
    #16
    you are not alone.... we've been dealing with this issue since the GM (some before).

    http://forums.macrumors.com/showthread.php?t=1374694

    The only apparent "fix" is to:

    Open up "Network Utility"
    Click the "Ping" tab
    Check the "Send an unlimited number of pings" button to google
    Click "Start" and leave running in background.

    ... If this doesnt work for you, you will need to restart your computer and first launch network utility.
     
  17. enklined macrumors 6502

    Joined:
    Sep 13, 2007
    Location:
    Sacramento
    #17
    Wow this is ****ing retarded. Trout, your solution didn't work either :(

    I'm now wondering if it has to do with Google Chrome - do any of you use Chrome? I've noticed the internet connection seems to work fine, until I fire up Chrome. Then dead. I can't make sense of why Chrome would be causing the issue, though...

    Going to use Safari for the day and see if that works.
     
  18. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
    #18
    And so it begins... :(

    I fail to understand why each and every new OS from Apple always seems to introduce new wi-fi problems.
     
  19. canucksfan88 macrumors 6502a

    canucksfan88

    Joined:
    Oct 28, 2007
    #19
    great...i cant stay connected for more than 2 mins...
     
  20. Eamonn macrumors newbie

    Joined:
    Jul 26, 2012
    #20
    Same problem. What a crap system.
    No wi fi at all.

    Why was this released without testing
     
  21. pepitko macrumors member

    Joined:
    Dec 24, 2007
    #21
    Similar problems here (early 2011 MBP), wifi icon shows that wifi and internet is connected, but internet works only for a short while and then gets slow on some pages, then doesn't load pages at all. I erased all preferred networks from my settings and after reconnecting the wifi icon showed "no internet connection." After a couple of minutes this switched to the regular wifi icon, but loading some webpages (macrumors.com, reddit, etc) is still quite slow but some other pages it is quite fast.

    This is in Safari, and I didn't have any similar problems with Lion. I have a TP-link router, all other devices in the house (iPads, iPhones, a Windows 7 desktop) work perfectly fine.
     
  22. bogatyr macrumors 65816

    Joined:
    Mar 13, 2012
    #22
    Two MBA 2011s, no issues yet. Verizon Mifi box, Cisco 1262 APs, Cisco 1252 APs and a Linksys E4200. Don't have any other APs to test with.
     
  23. Dunkaccino macrumors member

    Dunkaccino

    Joined:
    May 17, 2010
    #23
    This thread is a testament to why people really need to wait a week or so before deciding to upgrade the minute it hits the app store.
     
  24. ozp macrumors newbie

    Joined:
    Feb 23, 2009
    #24
    Using a different router fixed that for me.

    Just to be clear, the router was not the problem - I didn't had any problems with my connection until it started yesterday after installing ML and since then I had internet for no more that 2-3 minutes each time until I had to either reboot the router or turn the wifi on my mac off and on.

    So I have a feeling that this has to do with some combination of ML bug and some routers. Replacing the router fixed it for me (for now, it's already been 3 hours without losing connectivity), I know not everyone has a spare router that they can use as a replacement but I thought I would leave this message as FYI, might give someone an idea of how to really solve it.

    ----------

    Oh, and btw, the problematic router was a TP-Link router as well - like pepitko's
     
  25. MacAndMic thread starter macrumors 6502

    Joined:
    Jun 4, 2009
    #25
    The problem seems to be a routing issue. If you introduce a new router into the mix, then you have a "fresh" start. Others have reported that a clean install corrects the issue, concept again, a fresh start and nothing left over from the upgrade that ML is confused by.

    I've also seen other posts from past releases mentioning deleting your cache and system preferences to create a "fresh" start and they are fine now.

    Again, I've also seen posts about continued pinging of servers keeps the connection working which prevents the wireless card from going into power save mode. I personally believe ML is trying to go to sleep all the time and when awoke, forgets the addresses it is suppose to talk to.

    My problem still exists from a wake but if I go through the diagnostics assistant, and with IPV6 turned to local, it works fine for the entire session. This proves to me that ML is having issues with resolving network addresses.

    Just for yucks, I am going to rename my router tomorrow and see if this makes a difference. If you beat me to it, let me know your results. If this does not work, I will hard code the addresses, bypassing DHCP and see if that works.

    One thing is for certain, I am going to figure this out!

    troutspinner
     

Share This Page