Mounting a .dmg of a Linux drive

Discussion in 'Mac Basics and Help' started by Jtrivedi, Feb 20, 2011.

  1. Jtrivedi macrumors newbie

    Joined:
    Sep 2, 2009
    #1
    Hey guys,

    So today I took a 3.5" IDE hard drive and put it into an enclosure. There were four partitions on it, all Master Boot Record and all Linux partitions. When I plugged the drives into my Mac, the partitions showed up in Disk Utility, but because it was a Linux drive, it couldn't read it or anything.

    I needed to make a copy of all the partitions, so I clicked on the hard drive that includes all the partitions and I pressed "New Image" in disk utility.

    It made the image, but now when I try to open it, it gives me an error, "No mountable file system."

    All I want to do is be able to look inside the files that are in the .dmg. I have access to my Mac, as well as Windows and Linux. I just need to know how to explore/mount it.

    Thank you so much!
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    What format were your Linux partitions? OS X can't read ext2/3 natively. There are solutions to mount ext3 volumes in OS X, but you'll need to do the Google legwork yourself.

    P.S., your disk image you created probably doesn't have any usable data on it since the partitions weren't mounted and readable by OS X when you created it.
     
  3. Jtrivedi, Feb 20, 2011
    Last edited by a moderator: Feb 22, 2011

    Jtrivedi thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #3
    I'm not exactly sure. I would assume ext2, and I've already tried installing MacFUSE and the ext2 extension. Either way, if I try opening the .dmg in Disk Utility, and click 'Open', it will show the four partitions.

    'disk5s1'
    'disk5s2'
    etc.

    None of the disk5s# partitions do anything if I try to mount them via DU.
    The format just says 'Linux', or if I have the ext2 extension installed, ext2 or something.


    So theres no way I can get into the .dmg (or even the copy I converted to .iso)? :(

    Is it completely useless?

    Oh, and if the situation is still a bit blurry, I think this thread talks very briefly about the same problem I'm having.

    http://discussions.apple.com/thread.jspa?threadID=2675279

    I also tried the link at the bottom, which supposedly does the same thing as MacFUSE ext2. Still couldn't mount the partitions.
     
  4. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #4
    You said you had access to a Linux box, how about connecting it there and copying the files to another FAT drive?

    I've never worked with ext2 or any other Linux file system on the Mac but I'd be surprised if the MacFUSE solutions didn't work:
    http://ekettoz.blogspot.com/2009/06/mounting-linux-ext2ext3-partitions.html

    The file system could be something else. I'd suggest connecting it to your Linux box and find out exactly what it is.
     
  5. Jtrivedi thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #5
    Unfortunately I don't have access to the original drive. I only have the dmg image. I know, it's strange.
     
  6. maestroscott macrumors newbie

    Joined:
    Jun 20, 2008
    Location:
    Broad Channel, NY
    #6

Share This Page