Mounting data partition + Finder issue

Discussion in 'macOS' started by Tex-Twil, Jul 27, 2010.

  1. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #1
    Hello,
    I have now 2 disks in my MBP (SSD + HDD in Optibay). I want to use the HDD for data only storage and I would like to mount the disk in the folder

    Code:
    ~/Data
    
    So I created the dir and mounted the partition manually to test it :

    Code:
    sudo mount_hfs  /dev/disk1s2 /Users/me/Data/
    
    It works but there is a little annoyance:
    I open Finder and go to my Home dir. Now I enter the Data directory where my partition is mounted. First, the sidebar does not show now that I'm in my user directory. Now if I want to step one level up using Cmd + UpArrow, I do not go back to my home folder as expected but to a list of all my disks.

    Is there a way to fix that ?
     
  2. simplebeep macrumors member

    simplebeep

    Joined:
    Sep 28, 2007
    Location:
    SLC
    #2
    Unfortunately, the Finder is pretty unforgiving when it comes to mountpoints. I don’t have a drive to test this with, but try using something like this:

    Code:
    sudo mount_hfs -o nobrowse /dev/disk1s2 /Users/me/Data
    When I use Disk Images in this way, the nobrowse option helps soothe the Finder’s surliness a bit. Or, you could try this diskutil command:

    Code:
    diskutil mount -mountPoint /Users/me/Data disk1s2
     
  3. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #3
    Code:
    sudo mount_hfs -o nobrowse /dev/disk1s2 /Users/me/Data
    This at least does not show it in the Finder's side bar.

    but in both ways, the browsing of the mountpoint still has the behavior I mentioned.
     

Share This Page