Mounting NFS shares

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Kristan, Jul 4, 2011.

  1. Kristan macrumors newbie

    Jun 22, 2011
    Hi all,

    New mac convert and I'm trying to migrate some of my PC stuff over to the mac. I've got a Nexentastore (solaris clone) NAS box running which has been sharing files over SMB for my windows PC's. I can connect to the CIFS shares with the mac, but I was wondering if NFS is any better/faster.

    I've enabled NFS sharing on the nexenta box, but for the life of me I can't mount the drives.

    I've tried many variations on :

    sudo mount -t nfs nfs@nexenta:/pools/store/Documents /Volumes/documents/
    (nfs is the default user) but it either gives me "permission denied", "authentication failed" or "mount_nfs: can't get net id for host". I've read a multitude of docs that basically tell me "permission denied" is because the path is wrong, and "can't get net id for host" is because it can't resolve the hostname. I'm pretty sure both these things are ok (both machines can resolve each other, DNS domain is the same) and the path is correct.

    I'm at a bit of a loss as to where to go next - has anyone got any experience in this area?

  2. Mactasia macrumors member


    Jun 10, 2011
    Have you tried mounting the share via Go > Connect to Server... >


    Do you still get access denied?
  3. ratsg macrumors 6502

    Dec 6, 2010
    I am running several different flavors of Solaris myself (Nevada, OpenIndiana and Solaris 11 express), and have ran into similar issues myself.

    Does "showmount -e" show the filesystem(s) correctly shared?

    Is there any layer 3 networking devices between the server and client that might be blocking either NFS or RPC traffic?

    Those are just some basics that you have probably checked out already.

    When I have ran across this issue in the past, my typical resolution has typically been name resolution. You haven't provided many details in your note to help troubleshoot, but if this is in your home and/or using RFC1918 address space, a host file entry for the client might be enough to get things moving forward. I typically do well with this format

    <IP Address> client-FQDN client-hostname

    Hope this helps
  4. Kristan thread starter macrumors newbie

    Jun 22, 2011
    That actually doesn't do much - just very briefly flashes up the "connecting" dialog then disappears - without doing anything.

    showmount -e shows me the shares correctly, and the connection is literally

    MBP->airport->Nexenta box. Wireless or cabled results are the same (as you'd expect).

    The domain at home is home.local, and from the console both can resolve each other, either as FQDN's or just the hostname, and letting the dns client append the local domain. They're both in a subnet - but I don't see why the range would make a difference?

    I don't really want to add entries to the hosts file as it's a bit of a hack, DNS should be able to sort that out for me (and seems to be). Are there any log settings I can turn up/check? I'm still new to OSX and trying to find out where stuff lives!

    Thanks for the suggestions guys

Share This Page