Mouse Acceleration in OSX

Discussion in 'OS X Mavericks (10.9)' started by 827538, Mar 11, 2014.

  1. 827538 macrumors 65816

    Jul 3, 2013
    So I've had my first Mac since November and truly love it. I also really like OSX (aside from some really minor things).

    Well I've tried out the Magic mouse and while nice it's pretty useless for what I use it for (gaming) so I went and got a Logitech Performance MX - great mouse, so ergonomic unlike the Magic Mouse.

    But my biggest issue is Mouse Acceleration, it makes using the mouse a bit awkward, like trying to make small movements I always either over compensate or I don't move it enough. I would really appreciate a way to disable this for my mouse (and not for the trackpad).

  2. 827538 thread starter macrumors 65816

    Jul 3, 2013
    OK so I found a Terminal code to turn off mouse acceleration which works. But when I use that it turns to sensivity down several notches to a rather low point where it means I have to make big sweeping movements. This doesn't affect the trackpad which is good.

    defaults write .GlobalPreferences -1

    But as soon as I then try to increase the sensitivity to something reasonable to re-enables mouse acceleration. C'mon Apple seriously? Pretty much flawless OS and here Windows stamps all over you with simple MA on or off options.

    Any ideas?
  3. Small White Car macrumors G4

    Small White Car

    Aug 29, 2006
    Washington DC
    Have you installed Logitech'h control panel yet?

    I have no idea if it'll do what you need but that's where I'd start. I believe it'll put a panel in the system settings specifically fro logitech devices.
  4. 827538 thread starter macrumors 65816

    Jul 3, 2013
    Yeh I've done that, no option to change mouse acceleration, only to map different buttons.
  5. jpeezy macrumors regular

    Feb 24, 2010
    One word....... SteerMouse

    My cursor settings : 0.375 Tracking Speed, 250 Sensitivity

    You're Welcome! :)
  6. Pndrgnsvc macrumors 6502


    Jun 13, 2008
    Georgetown, Texas

    With my 27" display and a TrackPad, I found CoursorSense the perfect solution as it allows one to adjust both acceleration and sensitivity.

    You might want to give the demo a go. Shareware (US $9.99) at:
  7. 827538 thread starter macrumors 65816

    Jul 3, 2013
    $20 or $10 to fix mouse acceleration is a little ridiculous, think I'd rather just put up with this stunning but small display of stupidity from Apple. This is the first real thing I've come across where I think, 'what the hell Apple?', seems like such a straightforward thing to fix, a single checkbox for MA on or off.
  8. Shockre macrumors member

    Apr 4, 2009
    download steelseries exact mouse tool. free, 1 click on-off acceleration and nothing else.
  9. beosound3200 macrumors 6502a

    Nov 23, 2010
    if you want windows-like acceleration, try smoothmouse, its free and works great. i never could get used to os x mouse acceleration
  10. termhn macrumors newbie

    Nov 30, 2014
    If anyone else is looking for a solution, here goes:

    1. Download and unroll the tarball here:
    2. You should now have a file in downloads called killmouseaccel with no extension. I decided to rename it to killma (no extension still) for convenience and you should to to make the rest of the guide work.
    3. Right click and copy the newly renamed killma file
    4. In the top menu in finder click go and then go to folder and type in "/usr/local/bin"
    5. Paste (Command-V) killma into this folder
    6. You should now be able to open terminal (click spotlight or Command-Spacebar then type terminal) and then run:

    killma mouse

    to eliminate your acceleration.
    7. To make this automatically apply on startup, inside terminal do the following. It will ask for your password, when you type it it won't actually type any letters but you are actually typing. Just type in your password and hit enter:

    sudo mkdir /System/Library/StartupItems/killma && cd $_
    sudo nano

    7a. You're now in a little text editor. Type the following:

    #! /bin/bash
    killma mouse

    7b. Press Control-X and then Y when asked if you want to save the buffer

    7c. Now run:

    sudo chmod +x

    8. Done! It should kill your mouse accel at startup now.

Share This Page