Mouse and USB ports quitting at random

Discussion in 'MacBook Pro' started by fokkerpilot, Nov 30, 2011.

  1. fokkerpilot, Nov 30, 2011
    Last edited: Dec 3, 2011

    fokkerpilot macrumors newbie

    Joined:
    Oct 22, 2011
    #1
    Strange thing happening with the Logitech mouse I;m using on the MBP. Sometimes the port I am using just quits and I have to go to the other USB port. Then that might quit and I go back to the original port and it works. Running Snow Leopard 10.6.8

    Any ideas? I run the mouse with Firefox and no problem.

    Thanks in advance.
     
  2. fokkerpilot thread starter macrumors newbie

    Joined:
    Oct 22, 2011
  3. iVikD macrumors regular

    iVikD

    Joined:
    Sep 11, 2011
    Location:
    Spain
    #3
    I had a similar problem where the OS wouldn't recognize the USB ports (or nearly any other input.) I tried many solutions, but the only one that worked was reinstalling the OS from scratch.
    On a brighter note, maybe the issue is with your mouse? Does the USB port stop working altogether or only the mouse?
     

Share This Page