Mouse click not working properly help!

Discussion in 'Mac OS X Lion (10.7)' started by iOrbit, Mar 20, 2012.

  1. iOrbit macrumors 6502a

    Mar 8, 2012
    I just bought a macbook pro last week. Since using lion, I have noticed a problem clicking. Such as opening folders, minimizing windows, clicking the back space button etc. I click on a few folders and they open, and then I try to click on another one and it refuses to open no matter how many times I click on it unless I unselect it and try again. It is not consistent to specific folders/icons, it just happens at random. It is as if the OS is not registering clicks consistently, like it were a hardware problem. Also my right click malfunctions at times and will either not work or will behave like it is the left click and vice versa and takes awhile to regulate itself.

    Keep in mind I use both a wireless usb mouse and my trackpad and this is a problem I experience with both of them. I am using the latest version (10.7.3)
  2. ckau macrumors newbie

    Apr 2, 2012
    Mouse click not working

    I'm having the same problem, and it also just started and I suspect it is from an incompatible extension since if I start up with the Shift Key pressed (safe mode) the problem goes away. I'm also in Lion 10.7.3 and never had the problem before this latest Lion upgrade. My next plan is to see what extensions Lion 10.7.3 modified. I am using an older MacBook Pro.
  3. Partron22 macrumors 68020


    Apr 13, 2011
    You might have a look at the double-click speed setting, now found in the 'Universal Access' Prefs pane, under the 'Mouse Options...' or 'Trackpad Options...' button.

    Slow down the double-click speed a bit to A) give yourself a little more leeway in double-clicking, and B) modify the prefs value so that the prefs file gets rewritten with a reasonable value for double-click speed.
  4. ropiko macrumors newbie

    Apr 12, 2012
    Problems like this!

    I've got similar problems like this, it started when i was still using 10.6 and it's still there, upgrading to 10.7.3 didn't solve anything for me,

    The problems I experience are:
    - clicking a X (closing window) button, but instead it clicks that one next to it (the - (minimize) button).

    - In Safari when i try to close a tab, I can click the x button as many times as i want (and i see it actually get pressed) but it won't do anything.

    - When in iTunes a song is selected, and I want to drag it to a playlist, I have to de-select it and select/drag it right away or else it will just start playing the song over and over again (like i'm double clicking it but I'm not).

    Dragging my tab's or window's around solves the clicking issue for a bit, it gets responsive again.

    Strange thing is, I got these problems with 10.6 on my 2010 iMac, then I upgraded to a new 2011 iMac, but I did a clean install. i've only dragged the folders from my backup. I waited a while before upgrading to Lion and when I finally did (hoping the problems would go away) it's still there.

    I can live with it, but it's getting really annoying, and i can't find a solution anywhere. Hope this topic can help us :)

    - Robin
  5. greepo macrumors newbie

    Apr 24, 2012

    Hey guys,

    I've been having similar problems since upgrading to Lion and it's driving me round the bend. The main issue is clicking on Windows to shut them down (x). I can click a few and they work and then all of a sudden it doesn't. The remedy seems to be clicking somewhere else on the screen and then coming back to the X to click and it works. Very annoying.

    At first I thought it was a trackpad problem but I noticed it happens when my mouse is attached to my machine (MBP).

    If anyone has a solution or comes up with one, please share. It's the most annoying (ongoing) problem I've had in nearly ten years as a mac user.


  6. Johnnodrums, Jun 22, 2012
    Last edited: Jul 10, 2012

    Johnnodrums macrumors newbie

    Jul 23, 2011
    Mac mini not recognizing mouse clicks

    I have the same problem. I'm on a mid 2009 Mac Mini. I am running Lion 10.7.4 and I have found no solution for the problem. Dragging and dropping things can be really annoying. When I click once to select an item and sometimes registers it as a double click. Many times it registers a single click as a double click, or as a click hold or is just doesn't register it at all. I haven't noticed any problems with the right click. I have used several different USB mice and experienced the problem on all of them. The problem started out small but seems to getting worse especially if I have left the computer on for a while without restarting.

    I suspect a third party tool might be the culprit.
    Here are a list of Apps that I think could be causing the problem because the mess with mouse and keyboard settings.


    Anyone else have these installed?

    I am going to reboot in safemode to see if that works. If it does I am going to try a clean install to see if it fixes the problems... I will report back.

    [Update July 10 2012] I tried everything.... boot in safe mode.... reformat and nothing worked.... I had tried 3 different *cheap mice (1 Logitec 2 dell) and continued to experience the problem. I decided to try one more mouse (my friends advanced "Razer DeathAdder - 5-btn Mouse") and guess what it worked fine. So I went out and bought a new (still very basic) it also works.

    So it turned out to be a hardware problem in my case. If you are using a cheap overused mouse try a new one.

Share This Page