Mouse click problem on Powerbook

Discussion in 'PowerPC Macs' started by KevRC4130, Jan 16, 2009.

  1. KevRC4130 macrumors 6502

    Joined:
    Jul 1, 2004
    Location:
    Massachusetts
    #1
    I'm having a strange problem with my Powerbook: the mouse button does not do anything. The curser moves fine, but I cannot actually click. Sounds like the button is faulty, right?

    Here's the kicker: When I plug in an external USB mouse, the behavior is identical. Even weirder, I can right click with the mouse, but not left click.

    I've tried restarting, and even removing the battery. Any ideas?
     
  2. KevRC4130 thread starter macrumors 6502

    Joined:
    Jul 1, 2004
    Location:
    Massachusetts
    #2
    So in case anyone else is having this problem...


    An external mouse works until the trackpad is touched. The minute you move the curser or try to click using the trackpad/button, it's game over.

    So, I used an external mouse to simply deactivate the trackpad while a mouse is detected. Problem free ever since! Knock on wood.

    Of course, now a mouse is required for sure. Sure beats the hell out of not being able to click, though!
     
  3. Dreamail macrumors 6502

    Joined:
    Jun 17, 2003
    Location:
    Beyond
    #3
    Motherboard? Trackpad?

    I've got exactly the same problem now.

    All of a sudden, this morning my trackpad click stopped working.
    As if stuck on a right-click, all left clicks stopped working.
    I can do right clicks, but no left clicks.

    Tried the usual suspects, reset PRAM, PMU, tried external mice (2 different ones). Same everywhere.

    Seems clearly an issue with either the motherboard or the OS.

    Then I tried booting from the OSX 10.4 start DVD. Same problem. So it's not a corrupt OS. Perhaps a trackpad issue hogging the USB port?


    KevRC4130, thank you for your tip!
    That's exactly happening for me too.
    An external mouse does work fine (even left clicks) until I touch the trackpad once. Then no go.
    At least that way I can still use the laptop with an external mouse for now.


    Anyone ever found a solution or the actual cause?


    PowerBook 12" (2005 model), 1.33GHz, 1.25GB RAM.
     
  4. thomasgregersen macrumors newbie

    Joined:
    Apr 20, 2010
    #4
    Boot in safe mode did the trick for me.

    I have a MB Pro from 2008 and had that exact same problem.
    Neither my track pad nor my external mouse would generate a response when doing a left click.

    Tried all the resets mentioned with no luck.

    What seemed to work for me was starting the computer in safe mode where the mouse worked as it should and then restart into normal mode.

    Hope this will work for others too (I know I was extreemely frustrated!)

    Edition: Both me and my colleague experienced the problem again (on the same day...), but after a safe mode restart, it hasn't bothered us again. Weird stuff!

    Regards
    Thomas
     
  5. nanyleon macrumors newbie

    Joined:
    Jul 22, 2010
    #5
    similar problem - can't "unclick"

    I have a similar problem but my trackpad normally works and I use MacBook Pro. I couldn't find any other thread with the same problem.

    I use a wacom tablet with a mouse as well as the trackpad and it happened 2 different times when the cursor got stuck.

    1- I clicked on a window (finder) to move it to another side and it just got stuck on that window and doesn't "un-click" so the windows keeps moving with the mouse even if I'm not clicking.
    2- I was on Lightroom 3 moving a slide and same thing. The only thing that is moving is the specific slide.

    Now, the right clicks stills works but can't do much with it, I just can hide the program but not close it.
    When it gets stuck I can move the mouse and the trackpad but still doesn't un-click.
    The keyboard kind of works but I can't do com+Q to close the program.
    After I reboot it, works fine.

    Any thoughts?
     

Share This Page