mouse gestures in lion/chrome - can i disable by app?

Discussion in 'Mac Apps and Mac App Store' started by maigado, Nov 24, 2011.

  1. maigado macrumors member

    Joined:
    Oct 29, 2007
    #1
    Sometimes, when using Chrome (and probably any other browser) and a mouse (not an Apple mouse, in this case), I get unwanted actions from gestures. The main thing is that if I swipe the mouse to the left, the browser will navigate back a page in the history. That's fine when it's what I want, but when it's a byproduct of another action, it's annoying.

    Is it possible to disable mouse gestures in a particular app? I'm not seeing a way to do this in the System Prefs.

    Also, in Chrome, I often get a blue line that tracks my mouse cursor movement for the purposes of gestural behavior. So when I'm trying to select text, for example, that line is drawn instead and I can't do what I'm trying to do. I have to double-click to select a word or whatever, then use the keyboard to select the rest. It shouldn't have to be like that, obviously.

    Any thoughts on this?
     
  2. maigado thread starter macrumors member

    Joined:
    Oct 29, 2007
    #2
    Gotta bump. Still hoping someone has some ideas about this.
     
  3. roblawton macrumors 6502

    Joined:
    Oct 12, 2007
    Location:
    Preston, UK
    #3
    I'm sure BetterTouchTool would do the trick.

    You can change various settings for your mouse/trackpad and customise gestures. Worth a shot I guess! :)
     
  4. SkipperDan macrumors newbie

    Joined:
    Jun 6, 2010
    #4
    I had the same problem, found these directions somewhere on the internet:
    go to System Preferences > Track Pad > More Gestures then uncheck "Swipe Between Pages"
     
  5. maigado thread starter macrumors member

    Joined:
    Oct 29, 2007
    #5
    Thanks to both of you.

    I solved the blue line problem a couple of hours ago by going through my extensions. Drag and Go had mouse gestures built in, as it turns out. Turning those off fixed one thing.

    I'd already tried BetterTouchTool for the first item, but it hasn't worked for me, so far. I'd also tried unchecking the Swipe Between Pages switch, to no avail, strangely enough. But now that I've turned off those gestures in Drag and Go, it'll probably work now.

    Thanks again.
     

Share This Page