Mouse lag in clamshell mode

Discussion in 'MacBook Pro' started by mcvaughan, May 16, 2011.

  1. mcvaughan macrumors 6502a

    Joined:
    Aug 9, 2007
    Location:
    Houston, TX
    #1
    My MBP is connected to my 27" ACD and I'm experiencing mouse lag while I am using clamshell mode. I'm using a Magic Mouse, and it's all fine when using both displays at the same time. ???
     
  2. rikscha macrumors 6502a

    Joined:
    Mar 8, 2010
    Location:
    London
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    Finally someone with the exact same problem. Im having the same problem when connecting my MPB '10 to my tv. The mouse gets laggy after a while. I even had my mouse swapped by apple for a new one. didn't really help. What I exerienced as well is that the mpb itself acts a bit laggy after dIsconnecting it from my tv. Any idea?
     
  3. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #3
    Sorry to bump an old thread, but same problem here with a 13" MBA and 24" ACD. Haven't found a solution. Swapping mice didn't help.
     
  4. rikscha macrumors 6502a

    Joined:
    Mar 8, 2010
    Location:
    London
    #4
    I came to the conclusion that the BT chip in apples macbooks is rubbish. Can you use your magic mouse from a distance 1.5-2m away from your macbook without any lag? It is even worse when you are in clamshell mode but just in general when you are using your mba without hooking it up to your acd
     
  5. Lucagfc macrumors 6502

    Joined:
    Sep 23, 2008
    #5
    I' ve the same problem: my magic mouse was perfect when I used it with the MacBook Pro (17" Early 2011) opened. In Clamshell mode with the computer only 40 cm away the mouse become laggy! Any solution to this problem? thanks!
     
  6. Sace macrumors member

    Joined:
    Mar 30, 2008
    #6
    Had the same problem with the magic mouse on my 2009 13". Only solution was to open the lid a little and the the mouse lag disappeared.

    I think rikscha is right, it must be the BT chip that dosent have enough power to transmit properly through the closed lid.
     
  7. Lucagfc macrumors 6502

    Joined:
    Sep 23, 2008
    #7
    No one knows if it is possible to use an external USB Bluetooth pen drive and use it to connect keyboard ando mouse to the MacBook Pro? If it is possible this can be the only solution to use the MBP in clamshell mode and have a good mouse performance! I use the BookArc stand to save space on my desk and with that accessory I can' t open the MBP! Thanks
     
  8. Lucagfc macrumors 6502

    Joined:
    Sep 23, 2008
    #8
    I tried to use a Bluetooth USB dongle and all works great now! I simply repaired my Keyboard and mouse with the bluetooth dongle and all works great now: no mouse lags! Really disappointed to the Apple BLuetooth chip! they designed the MBP to run in clamshell mode but in real life you can' t do that unless you use an external bluetooth receiver!
     
  9. rheb1026 macrumors member

    Joined:
    Jun 19, 2011
    Location:
    Taxachusetts
    #9
    I am having this same problem. It's unbelievable. Same thing happens on my bootcamp partition, but much more extreme. I'm really disappointed I went and spent all this money on a display and bluetooth keyboard/mouse. The mouse and keyboard aren't even two feet away from my MBP!
     
  10. yansun, Jun 18, 2016
    Last edited: Jun 18, 2016

    yansun macrumors regular

    Joined:
    Mar 26, 2010
    #10
    Anybody else still affected by this issue? I'm on the newest El Capitan pb (15G7b) and the magic mouse lags noticable while my MBA (2013) is connected to a 24" Samsung SyncMaster and the lid is closed. When I open the MBA the lag immediatelly disappears, what indicates that clamshell mode really has something to to with it. The lag is so annyoing that I recently do not close the lid anymore although I have no use for the second (MBA) screen. It's really ridiculous that now in 2016 this issue (while searching about it I found a thread from 2009 in a forum) still seems to exist ...
     
  11. yansun macrumors regular

    Joined:
    Mar 26, 2010

Share This Page