Mouse Losing Connection

Discussion in 'Mac Accessories' started by GovtLawyer, Jan 29, 2014.

  1. GovtLawyer macrumors 6502

    Joined:
    Sep 6, 2008
    #1
    My new Magic Mouse is frequently losing the connection with my new iMac. The battery is at 97%. It loses and regains the connection within a 1/2 minute or so. This is a refurbed iMac. Could there be a problem with the bluetooth? Any suggestions how I can troubleshoot this to pinpoint the problem, or fix it?

    I am not using a mouse pad - just on a plain wooden desk. I doubt that's a problem as it has worked and tracked quite well for the three days I have had it, until today.
     
  2. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #2
    Do you have other BT devices? For me it was the mouse but only obvious since my BT KB didn't disconnect.
     
  3. GovtLawyer thread starter macrumors 6502

    Joined:
    Sep 6, 2008
    #3
    Other Devices

    Yes, I have both a wireless keyboard and a track pad. How many devices can connect at one time via bluetooth?
     
  4. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #4
    Is your keyboard Bluetooth wireless or some other type of wireless? If Bluetooth and the keyboard doesn't disconnect likely the mouse is the issue.
     
  5. mtbdudex macrumors 68000

    mtbdudex

    Joined:
    Aug 28, 2007
    Location:
    SE Michigan
    #5
    mine does this on/off - maybe every few days and I'm at 70% battery, but with this new security fix seems to do it way too much now, like every 10 minutes or so....... :(
    I'm 27-inch iMac, Late 2009, Software OS X 10.9.2 (13C64
     

Share This Page