Mouse problems since snowleopard.

Discussion in 'macOS' started by Bentov, Dec 12, 2009.

  1. Bentov macrumors regular

    Joined:
    Jul 22, 2007
    #1
    Ok, my first post went poof :( so to make this short and sweet. Since upgrading to SL I have had a lot of mouse problems. At first my logitech mx had a loss of fuctionality with most of the "extra" buttons. That was fixed in a later update, but now the mouse does move pause move thing. I uninstalled the driver and that didn't fix it. I tried going back to the mighty mouse, that had the problem. I tried the demo to steermouse with no luck either. My less than a year old mac pro is basically too frustrating to use. Any help would be greatly appreciated :)

    Thanks,

    B
     
  2. Bentov thread starter macrumors regular

    Joined:
    Jul 22, 2007
    #2
    I can't believe no one has had this problem besides me. I did find about it might be due to having two monitors. I guess I'll go down that path. Maybe I can do the leg work to save someone else the time if they have this issue later.

    Bentov
     
  3. Bentov thread starter macrumors regular

    Joined:
    Jul 22, 2007
    #3
    Went back to one monitor, no dice. The problem still exists. I really don't want to go back to leopard, but I don't think I have a choice. :(
     
  4. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #4
    Try resetting your SMC and PRAM. (Instructions on Apple's support site)
    Try putting in your Snow Leopard install disc and booting from it and see if that fixes the problem. If so, you may need a reinstall.
    Also, check your activity monitor and see if anything is really eating up your CPU usage (probably not the case because you're on a newer Mac Pro)
    Other than that, the only thing I can think of doing software-wise is repairing your disk permissions in the Snow Leopard installer Disk Utility. (That's pretty much the Mac user's equivalent of saying you just don't know.) You may want to call AppleCare as well.
     
  5. Bentov thread starter macrumors regular

    Joined:
    Jul 22, 2007
    #5
    Thanks for the reply, I finally found that I'm not alone:

    http://discussions.apple.com/thread.jspa?threadID=2130243&tstart=0

    It seems others have the issue and it is totally driver related. I did downgrade and then it was still borked, and then a clean re-install of SL, problem still there. It has to do with the ATI driver, if I use VGA the problem should go away. I got the adapter I needed, so we shall see.
     

Share This Page