Mouse Rollover Events Not Working

Discussion in 'macOS' started by darkomen242, Feb 11, 2012.

  1. darkomen242 macrumors newbie

    Joined:
    Feb 11, 2012
    #1
    Tonight I rearranged my living room and in the process cleaned and updated my Mac. After plugging my mac back in, all rollovers in all applications stopped working. When I hover at the bottom of my screen, where my dock is, it does not show. When I hover over a URL, an action menu, etc., the mouse icon does not change and the menu does not open. I have to click to interact with any rollover event.

    I am using a Mac Pro(10.6.8), 2.66 Intel Xeon Quad core, and an Nvida Gforce GT 120 and, since the mouse is relevant, I am using a Naga Razor.

    I have already tried restarting and unplugging my mouse and replugging it in. This yielded some results, but only fixed rollovers in Firefox. Also, this work around only persists until I shutdown my computer- then I have to repeat it. I also patrolled Google for others who are having this issue and everyone else resolved the issue by unplugging and replugging.

    Does anyone else have any ideas or insight? Any help would be appreciated.

    Thanks!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    How did rearranging your living room relate to your Mac? And how, exactly, did you "clean and update" your Mac?
     
  3. bungiefan89 macrumors 6502a

    Joined:
    Apr 5, 2011
    #3
    Multitasking. I often clean up my computer desktop when my REAL desktop or my room itself needs cleaning.

    And in response to OP, have you tried unplugging and re-plugging in your mouse? EDIT: Oh shoot, you did already. Erm... I'm stumped! Sorry man, I feel your pain though.
     
  4. Ddyracer macrumors 68000

    Ddyracer

    Joined:
    Nov 24, 2009
    #4
    just curious, are you using the razer synapse driver?
     
  5. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #5
    Does it also happen in another, even temporarily created, user account?
    Or does it also happen with another mouse?

    Did you by any chance use a cleaning app like CleanMyMac or MacKeeper?

    Five Mac maintenance myths
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Thanks, but my question was for the OP.
    That's what I was trying to find out. If the answer is yes, that could be the source of the problems.
     
  7. darkomen242, Feb 11, 2012
    Last edited: Feb 12, 2012

    darkomen242 thread starter macrumors newbie

    Joined:
    Feb 11, 2012
    #7
    Thanks for the speedy replies!

    By 'cleaned' I mean that I started a battle of compressed air vs dust and compressed air won. This means I didn't use a cleaning program. Since I expect this will be asked: When I clean I mainly focus on the fans, I never directly blow air at any exposed boards or rams. When the air does go toward exposed components I always use a slow stream to herd the dust away.

    I don't remember installing any drivers when I started using my Razor, so I don't think so.

    I made a new account and it had the same symptoms as my primary account. I also tested another mouse and the problem still didn't go away. It was a wireless Logitech.

    Morning Update: I tried updating my Mouse and System USB drivers. The mouse driver update did nothing, and Apple's website is having issues so I have been unable to get their USB driver maintenance software. I'm not sure if this is even the problem.
    I am also working on creating a new separate OSX partition on this computer. I want to have a clean fresh partition to see if the problem is there, if updating to 10.6.8 caused the problem, or if it is other software that I have installed.

    Update 2: I created the new partition, which I loaded with OS 10.5.6 straight from my original mac DvD. This new partition also had the rollover symptoms of my original partition.
     

Share This Page