Mouse Sensitivity Settings Keep Resetting

Discussion in 'macOS' started by dmfactor, Aug 1, 2010.

  1. dmfactor macrumors newbie

    Nov 25, 2009
    I use a Razer Deathadder and ever since I've started using it I've had to reset my sensitivity settings (via Apple -> System Preferences -> Mouse) after every system restart. I've read a bit about it online, some seem to think that deleting the Razer driver would work, but it hasn't for me. Any ideas on why the settings keep getting changed back to default?
  2. highres macrumors 6502a


    Jul 1, 2005
    Near the Singularity
    I've had the same problems too with my Logitech Performance DX. Usually I just have to open System Prefs and reset it. This even happens after waking up from sleep mode too. Mildly irritating.
  3. Cinder6 macrumors 6502


    Jul 9, 2009
    Resurrecting a semi-old thread that never got resolved. I have the same issue here, this time with a Razer Naga. Any ideas?
  4. Macdaddy1129 macrumors member


    Jul 6, 2010
    Bump. I just got a deathadder and i'm having the same problem.
  5. FreeflyPomme macrumors newbie

    Jan 24, 2011
    Bu-bump. Same problem here with the DeathAdder.
  6. DGenerate macrumors newbie

    Jan 27, 2011
    I just got a Death Adder too and I have the same problem. It seems like Mac OSX isn't recognizing the drivers until I play with them in some sort. This is really annoying.
    Also, it seems like USB Overdrive doesn't detect it so I can't use the app.
  7. Dyne macrumors member

    Jul 30, 2010
    I know this is an old thread, but I'm having the same exact issue. Has anyone been able to resolve this? :)
  8. glassflank macrumors newbie

    Mar 31, 2010
    I was able to fix this by downgrading my driver in Snow Leapord. After upgrading to Lion it resets with the old and new driver.
  9. plokoonpma macrumors member


    Mar 14, 2006
    Panama, Central America
    Really.... no fix??? Anyone knows how to reset mouse on the system or a command line?
  10. glassflank macrumors newbie

    Mar 31, 2010
    I couldn't fix it and had to un-install the razer mouse driver rather than reset the speed everytime I use the computer.

    I logged the issue with Razer and they said they were aware of it and working on new drivers.

    Seems to work fine without the drivers. I did find a tool that allows me to map the 4th and 5th buttons, to everything except the only 2 functions I want to use it for: Dashboard and Mission Control (Spaces).

    Oh well. If anyone knows of a tool that can map those functions to buttons let us know.

    Otherwise waiting on Razer
  11. plokoonpma, Aug 26, 2011
    Last edited: Aug 26, 2011

    plokoonpma macrumors member


    Mar 14, 2006
    Panama, Central America
    After I posted I decided to give it a try again and browse the whole dam support razor site with the hope to find something. From last time I looked they lack any reference of the problem but they have this:

    Then, they have this answer:
    Q: My Razer DeathAdder is double-clicking when I try to single click
    A: Please make sure you have the latest firmware installed on your DeathAdder. Please go to href= and flash the latest firmware to your DeathAdder. If you have any trouble with the flashing process or still have problems once the new firmware is installed, please contact our support team at the links below.

    I found the freaking firmware after a while since the link in the answer throws you to nowhere....
    1.40 firmware ---->,76,168,11,132

    SO if you are lucky enough to have bootcamp installed, download the 1.40 firmware above, install it and it will solve the problem. I still have mac driver version 3.0 and still had to tweak after restart cursor speed at system preferences BUT NO MORE DOUBLE CLICKING on single click.

    Hope it helps, still would like from them a proper fix on Mac.
  12. Anim, Jun 30, 2014
    Last edited: Jun 30, 2014

    Anim macrumors 6502a


    Dec 16, 2011
    Macclesfield, UK
    Again this issue has re-surfaced but on my Deathadder 2013 model and Mavericks. Anybody know a solution?


    EDIT: Just installed Synapse 2.0 from the Razor website and this software seems to override the tracking speed preference settings after boot.
  13. victorstan macrumors newbie

    Aug 16, 2015
    Sorry to bump a 1 year old thread, but just installed Synapse 2 for my DeathAdder 3.5G and after every sleep the sensitivity resets to minimum. This makes the Synapse setting useless as even on 3500 dpi, it feels like 500 due to the minimum system sensitivity.

    Anyone managed to find a solution? I have both Synapse and Firmware updated to the latest version... I might just uninstall the damn Razer crapware, but I need those 2 extra buttons. Any way to get them enabled in OSX without going the Synapse way?
  14. sh1sh1n11 macrumors newbie

    Nov 4, 2015
    I don't know if anyone has noticed it but I realized that "Tracking speed" under "Mouse" inside "System Preferences" in Mac OS X El Capitan is basically mouse acceleration. The reason it keeps resetting is because inside razer synapse 2.0 under "PERFORMANCE" the "ACCELERATION" has been set to "0" (Zero). Personally, I prefer the acceleration to be set to zero as I am an FPS gamer and having mouse acceleration ON messes with mouse precision and accuracy. Hope this helps to all those folks out there, Peace!
  15. Justinoes macrumors newbie

    Jan 26, 2016
    I realize that this might not be a popular suggestion, but I was experiencing a very similar problem with my iMac and magic mouse. It persisted when I upgraded to an iMac 5k (I used the migration tool.) I suspect this was due to (at some point) installing Magic Preferences. Since it was a new computer I opted to just do a clean install of OS X, which solved my problem.

    I suspect that something happens when you install some sort of third party mouse driver / configuration utility. Bottom line, a clean install of OS X - for me - was better than constantly tweaking the tracking speed.

    Best of luck,
  16. t1n0m3n macrumors newbie

    Aug 6, 2014

    Similar issue. After sleep, my Logitech G600 seems to have the equivalent of the "Tracking Speed" setting set to the lowest setting. The setting is NOT represented in "System Preferences/Mouse/Tracking Speed" visually. I keep that set to 6/9 always. However, I can correct the issue if I simply unplug/plug the mouse. Tracking speed goes back to normal.

    I have this issue with every USB mouse that I have tried. (A metric sh*t-ton of them over the years.) I always viewed it as yet another Mac bug that has never been fixed. I have had this problem for years, across many hardware/versions/installs. It is something that I have just gotten used to dealing with.
  17. whatismynamexD macrumors newbie


    Oct 14, 2016
    SOLUTION: Change the Acceleration settings to your desired mac setting then change the DPI
  18. t1n0m3n macrumors newbie

    Aug 6, 2014
    Hmm, not sure you actually read this thread... Maybe read it one more time for comprehension and then edit your post? Or maybe edit it to clarify what you intend to say.
  19. weirdlittleones macrumors newbie


    Nov 5, 2017
    He's actually right! He just didn't explain it.

    You go into your razer synapse settings, and set the "acceleration" on the performance tab for your mouse to about what you would set your mac's mouse sensitivity to. Apparently the acceleration setting overrides and sets the macOS's sensitivity settings.

    I noticed that if I set the razer acceleration to about the ninth mark it'll translate to the eighth mark in macOS settings. It might take a few tries to get it right.

Share This Page