mouse stops or lags when loading a program ?

Discussion in 'macOS' started by stuartrozier, Aug 4, 2015.

  1. stuartrozier macrumors regular

    Joined:
    Nov 12, 2011
    #1
    Hello,

    since owning my mac from last September, my magic mouse has worked perfectly - doesn't get a lot of use - probably about an hour a day.
    the battery percentage is still nearly at 3/4s.

    for some reason, up until recently, when opening a program, or opening up a page in safari - opening iTunes, can be anything,
    the mouse will lag, move slowly or jutter, when moving across the screen, but ONLY whirls the process is loading -
    after the process has loaded, its back to moving freely and smoothly,

    is this a memory/ram issue ?

    many thanks in advance
    stuart
     
  2. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #2
    oh an have tried another mouse, also with diff batteries to eliminate its a device problem - hope its not the bluetooth within the mac :(
     
  3. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #3
    OS X Version?
    What kind of Mac?
    Does this happen in Safe Boot?
    What types of programs are loading?
    Have you cleared the NVRAM/PRAM?
    Has an SMC reset been completed?
    What other wireless devices are near your computer and mouse?
     
  4. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #4
    el capitan public beta
    mac mini
    not sure about safe mode
    just safari and iTunes , finder, anything really that entails loading
    not tried a rest of these but will attempt now

    only other wireless device is bluetooth speaker, but have turned off to eliminate this - actually, apple watch to iPhone ?
     
  5. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #5
    i have since tried all that you have suggested, apart from safe mode
     
  6. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #6
    How are other Bluetooth devices operating with this computer? Do the bluetooth speakers have any issue?
     
  7. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #7
    coincidently, the problem has started since i got my new bluetooth speaker, the sound link mini kept cutting out.

    but had read it was a wiifi issue, so turned off wifi, an it stayed connected.

    but the mouse issue is still occurring, shall i try in safe mode ?

    the sound link has been turned off, and is now still turned off, in my bluetooth devices i only have one connected device, which is the magic mouse, shame i can't attach a small vid clip of whats happening.
     
  8. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #8
    ok, I'm currently in safe mode, replying to you now, waving the magic mouse across the screen - and its continuing to stutter across the screen, doesn't want to keep up with me, keeps juttering behind my hand movements,
    have never seen anything like it before,

    have turned off every bluetooth device in the house, even powered down the apple watch.
     
  9. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #9
    ....panic over ...

    tried a second attempt with a different magic mouse, and its working - so a faulty magic mouse -

    strangely it didn't work last time, may just be intermittent
     

Share This Page