Movie Artwork Missing in iTunes 8

Discussion in 'Mac Apps and Mac App Store' started by awr, Sep 9, 2008.

  1. awr macrumors member

    Joined:
    Sep 25, 2007
    #1
    Has this happened to anyone else? After updating to iTunes 8, all of my movies in grid and coverflow view have an icon that is black and says "participant productions". <----very strange, i have never seen that before.

    However, when i go to "get info" on any given movie, it shows the correct artwork in the info pane that i had previously assigned to it.

    I have tried deleting the previously assigned artwork and re-assigning an image, but in grid and coverflow, it just keeps showing the black rectangle icon reading "participant productions".

    Any ideas?

    Thanks guys.
     
  2. awr thread starter macrumors member

    Joined:
    Sep 25, 2007
    #2
    OK, so i figured out that the "participant production" icon was actually a screen grab from one of my movies that i did not have artwork for: "good night and good luck" - so that makes this a little less weird.

    So i guess my real problem is, I am seeing the same cover art (which is a screen grab from one of my movies) for all movies in iTunes.

    Also, of mention . . . i have my apple TV set to stream my entire itunes library, and on apple tv, the correct artwork shows up for each movie . . . .so the problem seems to be just in itunes, and not with the tag info on the files themselves.

    any ideas?

    Thanks.

    Update: i have successfully changed the art work for "goodnoght and goodluck" to the proper art, which has also changed artwork for all other movies to be the same artwork as that movie.

    Any suggestions?

    Thanks.
     

Share This Page