Movies won't sync, handbreak makes it worse

Discussion in 'iPhone' started by tac22, Aug 16, 2010.

  1. tac22 macrumors 6502

    Joined:
    Jun 16, 2009
    #1
    All of my movies in iTunes, which all play fine (they are ripped DVD movies) they all won't sync to my iPhone or iPad. And when I put them through handbrake through preset apple tv or iPhone setting what happens is let's say the movie is 1.5 hours, well it comes out so the total length is like 4.5 hours. The video is fine, but the audio is stretch out for the entire 4.5 hours(/so it's like slo mo) it's just black with the stretched out sound after the 1.5 hours of video.

    The movie does sync after however it's not as entertaining, I'd rather have the audio lined up.

    Does anyone know a fix, if you need anymore info about what I'm doing go ahead and ask spastics.

    Thanks... I need to put my 64gb on my iPad to use, same thing with my iPhone

    Details asked:
    iPhone 4
    iMac
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
  3. tac22 thread starter macrumors 6502

    Joined:
    Jun 16, 2009
    #3
    Mac and yes iPhone 4, iPad problems as well, I've never tried syncing my movies to anything else like an iPod. But they have always worked in iTunes when watching a movie using my apple remote, so I was disappointed when it didn't sync, even more so when handbrake ended up being the opposite of a solution
     
  4. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #4
    Check that you have the newest VLC player:
    http://www.videolan.org/vlc/download-macosx.html

    Then make sure you have the 32 bit version of Handbrake:
    http://sourceforge.net/projects/handbrake/files/0.9.4/HandBrake-0.9.4-MacOSX.5_GUI_i386.dmg

    Erase the one you have and download that, just to be safe. I don't think the VLC program works as 64 bit yet, so the 64 bit Handbrake doesn't work with it.

    Make sure you have the 32 bit version of each (you can tell by searching for "Activity Monitor" and runing that. Open both apps and check them out in Activity monitor).

    Because you have the iPhone 4, try using the "Apple TV" default setting. That should work fine on there since you're ripping DVDs and not HD movies. I don't have an iPad, but I think it should work on that too.
     
  5. UCLAKoolman macrumors 6502a

    Joined:
    Jun 21, 2010
    #5
    I usually encode on the normal or high profile settings, so that my movies will look decent on my PS3 as well as my iPhone 4. Of course I just rename the file to .mp4 for my PS3 and .m4v for my iPhone. Haven't had any trouble with syncing these files to my iPhone with iTunes.
     
  6. tac22 thread starter macrumors 6502

    Joined:
    Jun 16, 2009
    #6
    okay, i just did all of that, however in activity monitor it is saying that vlc is running at 64 bit

    also you need to explain how using vlc and handbrake together can hopefully get my movies in a format that will sync to my iphone. I use VLC all the time to play odd files on my mac, just don't know if it has other properties and how to use them

    Oh and thanks i hope you can help
     
  7. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #7
    Ok, this is new. So perhaps you CAN use the 64-bit version of both. Try that. They just need to match is all.

    What's happening is the Handbrake uses VLC behind the scenes to get the job done. Basically, if Handbrake had all the VLC stuff in it then it'd get in trouble for being able to rip DVDs. But Handbrake doesn't have everything it needs to rip DVDs! So they can't get in trouble. Instead, it uses VLC to help it get the job done. Since neither program has all the parts to rip DVDs, they can't get in trouble for offering a program that rips DVDs.

    You don't have to open VLC at all...just leave it in the Applications folder.

    But I didn't know about the 64 bit VLC. That's news to me. So try the 64 bit Handbrake and see what you get.
     
  8. tac22 thread starter macrumors 6502

    Joined:
    Jun 16, 2009
    #8
    i just ran through a piece of my movie on handbrake, only a minute long so it doesn't take hours and its the same thing, its like 3 minutes now with stretched audio... didn't really expect it work... its basically what i've been doing

    But thanx i still appreciate your contribution
     
  9. tac22 thread starter macrumors 6502

    Joined:
    Jun 16, 2009
    #9
    Well i downloaded the 64 bit handbrake again. closed vlc since you said it doesn't need to be open.

    Unfortunately when i run through my short minute clip of one of the movies i still get the same problem. i didn't change any setting in handbrake, just put it in there

    I've had these movies on my computer for a while, would it be different if they were HD, i think a have a few that are, they are all under 720p though
     

Share This Page