Moving files confusion

Discussion in 'Mac Pro' started by Washac, Mar 25, 2010.

  1. Washac macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #1
    Hi All


    Recently started using SD cards and Mem Stick ProDUo cards.

    Problem is I cannot seem to get the files that I wish to move or copy onto the cards
    I get this error message :

    The Finder can’t complete the operation because some data in “Inimaker.gpe” can’t be read or written.
    (Error code -36)

    The files can be moved or copied withing my Mac absolutley fine, just happens
    when trying to move to the mem cards.

    There is nothing wrong with the files by the way....
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  3. Washac thread starter macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #3
    Nope....
     
  4. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #4
    How about going into Disk Utility and formatting them?
     
  5. Washac thread starter macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #5
    Think I have it, maybe...

    Is it anything under 4GB you can Drag n Drop ?
    Anything over 4GB Copy n Paste ?
     
  6. GadgetGeek71 macrumors 6502

    Joined:
    Mar 5, 2010
    Location:
    Wherever I May Roam
  7. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #7
    It has to do with file systems. http://guides.macrumors.com/Drives_and_Filesystems

    Most flash memory cards (or maybe even all) come pre-formatted with the FAT32 file system, which allows them to be read and written to by Windows and Mac OS.
    But the disadvantage is the maximum file size, which is 4GB.


    So it has nothing to do with drag and drop or copy and paste and its use depending on file size, as that would be quite illogical.
     
  8. seveej macrumors 6502a

    seveej

    Joined:
    Dec 14, 2009
    Location:
    Helsinki, Finland
    #8
    I have a very similar problem when using a (any of my four card readers produce the same behavior) USB card reader to copy the digital images (10-20 meg RAW's) from my CF cards.

    When I select them all and drag them to where I want to move them the computer starts copying the files and then (always at some stage) interrupts the copying and gives a similar error:
    "The operation can't be completed because the item "_MG_1897.CR2" is in use." <OK> (No error code, nothing left in system logs.)



    This is a huge annoyance, and as sometimes it only copies one or two files before throwing that error and:
    - It only occurs when copying directly from a memory card to a remote disk (ext2 -volume on DNS-323)
    - If I let aperture/lightroom do the copying there's no error, but that does not fit my workflow
    - If I launch parallels and use WindowsXP to access memory card and destination drive then there's no problem
    - I've even written a crappy software with Director (ancient, eh?) to move the files and it's slow but works.
    - I've had the same problem with my iMac(i7) and my MacBook Uni(Al) (10.5 and 10.6) and both times it has been circumventable by using anything else than finderor using finder to fist copy the CF-card contents onto a local HD destination and then copying them from there to the remote drive...

    Ideas?
     
  9. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #9
    It is a SL bug (solution is there too):
    http://discussions.apple.com/thread.jspa?messageID=11222336

    http://discussions.apple.com/thread.jspa?messageID=11014297

    Edit:
    fixed links :)
     
  10. Washac thread starter macrumors 68020

    Washac

    Joined:
    Jul 2, 2006

Share This Page