MP09:Crucial m4 working only at SATA I

Discussion in 'Mac Pro' started by HHarm, Jan 2, 2012.

  1. HHarm macrumors regular

    Joined:
    Mar 4, 2009
    #1
    I have a MP09. I bought a Crucial m4 256 GB SSD for Windows 7 (64-bit).

    It only works in SATA I. I updated the m4's firmware but it didn't help. I have my 6 SATA connectors fully used but I've tried different configurations and even with every other drive unplugged the m4 still only does SATA I.

    Is there a way to solve the issue and reach SATA II?
     
  2. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #2
    FWIW I had an OWC 6G that did this on my 2008 MBP. I swapped it for the SATAII (slower) SSD as it negotiated correctly. Problem with Apple and sandforce firmwares. Maybe the same issue with Crucial?
     
  3. khollister macrumors 6502a

    khollister

    Joined:
    Feb 1, 2003
    Location:
    Orlando, FL
    #3
    I have a M4 in a 2010 MP and it negotiates to SATAII properly. That is not the case with some non-Intel host adapters - I tried the Crucial in a Oxford external SATA II enclosure with a eSATA PCIe card and only got SATA I speeds.

    There is also a known issue with some of the older MBP's.
     
  4. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #4
    Curiously the older 6G firmware worked at SATAII on my 2008 MBP. It died and the new firmware on the RMA'd SSD did not work. Just to clarify. OWC also added a blurb on their site after the fact.:confused:
     

Share This Page